Bug 172013 - selected repos don't match files in yum.repos.d
selected repos don't match files in yum.repos.d
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 172014 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 23:35 EDT by Eric Harrison
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 04:29:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Harrison 2005-10-28 23:35:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050926 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
yumex ignores the "enabled" flags set in /etc/yum.repos.d/*.repo, it is hard-coded to enable the base, updates-released, and extras repositories and to disable all other repositories.

Version-Release number of selected component (if applicable):
yumex-0.42-7.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Change the default "enabled" settings in some of the /etc/yum.conf.d/*.repo config files
2. Start yumex
3. Click on "Repos"
4. Note that base, updates-released, and extras will be selected, all other repos deslected, independant of the /etc/yum.conf.d/*.repo settings.

Actual Results:  Yumex reads the yum repositories, but ignores the "enabled" flags set on those repos

Expected Results:  Yumex would match yum's enabled repos

Additional info:


Filed upstream as well:

http://linux.rasmil.dk/cms/modules/newbb/viewtopic.php?viewmode=flat&topic_id=2&forum=2
Comment 1 Tim Lauridsen 2005-10-29 01:00:34 EDT
It is the way yumex is designed to work, in yumex you can make profiles with
diffent repositories selected, som you in a fast can select group of
repositories to use.
Maybe there sould be a profile called "enabled" there always contains then
repositories enabled in the *.repo files. 
Comment 2 Eric Harrison 2005-10-29 01:49:34 EDT
A DEFAULT profile called "enabled" that contains the repositories enabled in the
*.repo files would be perfect!

I really like the profiles concept. Being able to quickly select a group of
repositiories is a nice feature. I don't mean to suggest that this feature
should be removed or modified, only that the default behavior is changed.

The *default* profile needs to match the yum *.repo files. Users expect to be
able to switch back-and-forth between using yum from the command line and using
yumex as a gui front-end to yum. Yumex, as a gui-frontend to yum, should behave
the same as yum (at least by default).

Please note that this is not an imaginary or hypothetical issue. I am aware of
several systems that have been damaged due to yumex's unexpected behavior of
ignorning customizations to yum repositories.

Comment 3 Ignacio Vazquez-Abrams 2005-10-29 01:52:43 EDT
*** Bug 172014 has been marked as a duplicate of this bug. ***
Comment 4 Tim Lauridsen 2005-10-29 02:00:44 EDT
I will make a *defailt* profile there contains the current yum enabled state and
use it as the default profile when yumex starts.
Comment 5 Tim Lauridsen 2005-11-03 04:29:42 EST
In the current development branch in CVS(0.43), i have made the 'Std' profile
reflect the current enable state in yum.conf and *.repo files.
It will be released in Yum Extender 0.44.

Note You need to log in before you can comment on or make changes to this bug.