Bug 172020 - Rebuilding of coreutils 5.92 fails at mkdir testing
Summary: Rebuilding of coreutils 5.92 fails at mkdir testing
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-29 13:04 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 5.93-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 09:49:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2005-10-29 13:04:12 UTC
Description of problem:
While rebuilding latest coreutils from Rawhide, I get the following error 
messages:

[...]
make[3]: Leaving directory `/usr/src/redhat/BUILD/coreutils-5.92/tests/misc'
make[2]: Leaving directory `/usr/src/redhat/BUILD/coreutils-5.92/tests/misc'
Making check in mkdir
make[2]: Entering directory `/usr/src/redhat/BUILD/coreutils-5.92/tests/mkdir'
make  check-TESTS
make[3]: Entering directory `/usr/src/redhat/BUILD/coreutils-5.92/tests/mkdir'
FAIL: p-3
PASS: p-1
PASS: p-2
PASS: special-1
PASS: perm
PASS: parents
PASS: t-slash
======================================
1 of 7 tests failed
Please report to bug-coreutils@gnu.org
======================================
make[3]: *** [check-TESTS] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/coreutils-5.92/tests/mkdir'
[...]

Version-Release number of selected component (if applicable):
coreutils-5.92-1

How reproducible:
Everytime, try to rebuild latest coreutils.

Actual results:
Rebuilding of coreutils 5.92 fails at mkdir testing

Expected results:
Building without failure... ;-)

Comment 1 Mamoru TASAKA 2005-10-31 16:20:29 UTC
I am faced with this problem, too, if rebuilding rpm as root.

This is because root can execute "mkdir" on the directory of no permission
( perhaps this is the default ). So the failure occurs at the line 29 of
p-3 test.

Comment 2 Mamoru TASAKA 2005-11-10 04:22:34 UTC
This bug is perhaps fixed in coreutils-5.93-1 (at least for me, 
rebuilding coreutils 5.93-1 suceeds.)

From /usr/share/doc/coreutils-5.93/ChangeLog.bz2:
2005-10-30  Paul Eggert  <eggert@cs.ucla.edu>

        * tests/mkdir/p-3: Require that the test be run as non-root.
        Problem and trivial fix reported by Theodoros V. Kalamatianos.


Note You need to log in before you can comment on or make changes to this bug.