Bug 172036 - video card configure does not work
Summary: video card configure does not work
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
: 176289 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-10-29 17:33 UTC by Gene Czarcinski
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-03 03:38:56 UTC
Type: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2005-10-29 17:33:35 UTC
Description of problem:

WHen I try to configure the video card (driver) by pressing the configure button
(which works fine on FC4), I get:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 345, in
configure_videocard
    self.state)
  File "/usr/share/system-config-display/videocardDialog.py", line 63, in __init__
    selection.select_iter(videocard_store.get_iter_first())
TypeError: iter should be a GtkTreeIter

and I am unable to configure the driver.

Version-Release number of selected component (if applicable):
system-config-display-1.0.32-1

Comment 1 Reuben Farrelly 2006-01-02 08:00:08 UTC
I am seeing this also with Rawhide as of today 02 Jan 06, but it may have been
present for some time before.

Initially I had a GeForce 5700 PCI-e configured, but have recently upgraded to a
GeForce 6600GT.  Using system-config-date I am unable to reconfigure, in the
Hardware tab I click on "Configure" and a trace similar to the above is sent
back with no visual response to the end user and no option to reconfigure at all.

This I believe should be a blocker bug for FC5.


Comment 2 Sander Hoentjen 2006-01-02 12:52:36 UTC
*** Bug 176289 has been marked as a duplicate of this bug. ***

Comment 3 Søren Sandmann Pedersen 2006-01-05 19:10:00 UTC
I agree that this should be a blocker.



Comment 4 Søren Sandmann Pedersen 2006-01-12 18:54:59 UTC
Do you still see this problem? I can't reproduce it anymore.


Comment 5 Reuben Farrelly 2006-01-14 10:14:31 UTC
Yes, it's still completed busted and displays the same errors as before.

This is with system-config-display-1.0.33-1.1 (in rawhide)


Comment 6 Adam Jackson 2006-03-03 03:24:01 UTC
Unable to reproduce with system-config-display-1.0.36-2.  Could someone
experiencing this bug provide more details on their setup when s-c-d is run,
including gtk and python versions and xorg.conf file?

Comment 7 Adam Jackson 2006-03-03 03:38:56 UTC
Two other cases of worksforme from matthias and notting, so moving to
WORKSFORME.  Please reopen if you're still experiencing this.

Comment 8 Reuben Farrelly 2006-03-03 10:39:25 UTC
Yep WORKSFORME now too so I won't be reopening it ;)



Note You need to log in before you can comment on or make changes to this bug.