Bug 172037 - need updated ATI device list for s-c-d
need updated ATI device list for s-c-d
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 178562 (view as bug list)
Depends On:
Blocks: FC6Target FC6Desktop
  Show dependency treegraph
 
Reported: 2005-10-29 13:39 EDT by Gene Czarcinski
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:17:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vvn run on FC5 (8.64 KB, text/plain)
2006-07-26 08:42 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2005-10-29 13:39:40 EDT
Description of problem:

This may be related to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=172036

s-c-display does not recognize the RADEON X300 PCIE video card and, instead,
selects the vesa driver.

s-c-display works fine on FC4.

system-config-display-1.0.32-1 seems to work OK on non-PCIE adapters (e.g., ATI
Radeon R200 QM [Radeon 9100])

Version-Release number of selected component (if applicable):
system-config-display-1.0.32-1
Comment 1 Gene Czarcinski 2006-01-30 15:25:04 EST
still there in fc5-t2
Comment 2 Rahul Sundaram 2006-02-20 05:43:08 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Adam Jackson 2006-06-27 14:42:32 EDT
*** Bug 178562 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Clasen 2006-07-06 17:56:50 EDT
Add to FC6Destop tracker
Comment 5 Mike A. Harris 2006-07-26 07:57:08 EDT
Video hardware autodetection is done by querying PCI bus for class 0300
devices and obtaining their PCI device IDs, then looking through the
*.xinf files included with the video drivers to see if one of them supports
the given PCI device ID.

In order to add autodetection of any video hardware, we mandatorily require
the complete PCI ID for the hardware, the name of a video card, model number
or other information is not enough.

I am going to review the current ATI driver and will update the ati.xinf
file with any PCI IDs that I find which are missing, however I have no
way of knowing wether your specific chip will end up being added until
you submit the PCI ID.   Either an X server log file, or the output of
lspci -vvn is fine.

TIA
Comment 6 Gene Czarcinski 2006-07-26 08:42:25 EDT
Created attachment 133069 [details]
output of lspci -vvn run on FC5
Comment 7 Adam Jackson 2006-07-27 17:17:25 EDT
Should be sorted in xorg-x11-drv-ati 6.6.1-6.fc6, if not earlier.
Comment 8 Mike A. Harris 2006-07-28 01:19:43 EDT
Indeed:
alias pcivideo:v00001002d00005B60sv*sd*bc*sc*i* radeon # RV370

Note You need to log in before you can comment on or make changes to this bug.