Bug 1720615 - [RHEL-8.1] yum update fails for rhel-8 glusterfs client packages 6.0-5.el8
Summary: [RHEL-8.1] yum update fails for rhel-8 glusterfs client packages 6.0-5.el8
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
: 1720620 (view as bug list)
Depends On:
Blocks: 1720079
TreeView+ depends on / blocked
 
Reported: 2019-06-14 11:17 UTC by Niels de Vos
Modified: 2019-06-15 03:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1720079
Environment:
Last Closed: 2019-06-15 03:57:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22868 None Merged build: always build glusterfs-cli to allow monitoring/managing from clients 2019-06-15 03:57:57 UTC

Description Niels de Vos 2019-06-14 11:17:55 UTC
+++ This bug was initially created as a clone of Bug #1720079 +++

Description of problem:
yum update fails with the below error for RHEL-8 client packages

Error: 
 Problem 1: cannot install both glusterfs-debuginfo-6.0-5.el8.x86_64 and glusterfs-debuginfo-3.12.2-40.2.el8.x86_64
  - package glusterfs-cli-debuginfo-3.12.2-40.2.el8.x86_64 requires glusterfs-debuginfo(x86-64) = 3.12.2-40.2.el8, but none of the providers can be installed
  - cannot install the best update candidate for package glusterfs-debuginfo-3.12.2-40.2.el8.x86_64
  - problem with installed package glusterfs-cli-debuginfo-3.12.2-40.2.el8.x86_64
 Problem 2: package glusterfs-cli-3.12.2-40.2.el8.x86_64 requires glusterfs-libs(x86-64) = 3.12.2-40.2.el8, but none of the providers can be installed
  - cannot install both glusterfs-libs-6.0-5.el8.x86_64 and glusterfs-libs-3.12.2-40.2.el8.x86_64
  - cannot install the best update candidate for package glusterfs-libs-3.12.2-40.2.el8.x86_64
  - cannot install the best update candidate for package glusterfs-cli-3.12.2-40.2.el8.x86_64
 Problem 3: problem with installed package glusterfs-cli-3.12.2-40.2.el8.x86_64
  - package glusterfs-cli-3.12.2-40.2.el8.x86_64 requires glusterfs-libs(x86-64) = 3.12.2-40.2.el8, but none of the providers can be installed
  - cannot install both glusterfs-libs-6.0-5.el8.x86_64 and glusterfs-libs-3.12.2-40.2.el8.x86_64
  - package glusterfs-6.0-5.el8.x86_64 requires glusterfs-libs(x86-64) = 6.0-5.el8, but none of the providers can be installed
  - cannot install the best update candidate for package glusterfs-3.12.2-40.2.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages

Version-Release number of selected component (if applicable):
glusterfs-6.0-5.el8
RHEL-8.1

How reproducible:
Always

Steps to Reproduce:
1. Have a RHEL-8.1 system with all glusterfs packages built for rhel-8 client
2. Add latest glusterfs rhel-8 client repo
3. yum update

Actual results:
Failed to upgrade

Expected results:
Should upgrade to "6.0-5.el8"

Additional info:
Packages already available in systems
# rpm -qa | grep gluster
glusterfs-libs-3.12.2-40.2.el8.x86_64
glusterfs-rdma-3.12.2-40.2.el8.x86_64
glusterfs-rdma-debuginfo-3.12.2-40.2.el8.x86_64
glusterfs-client-xlators-debuginfo-3.12.2-40.2.el8.x86_64
glusterfs-debuginfo-3.12.2-40.2.el8.x86_64
python2-gluster-3.12.2-40.2.el8.x86_64
glusterfs-fuse-debuginfo-3.12.2-40.2.el8.x86_64
glusterfs-3.12.2-40.2.el8.x86_64
glusterfs-api-3.12.2-40.2.el8.x86_64
glusterfs-api-devel-3.12.2-40.2.el8.x86_64
glusterfs-api-debuginfo-3.12.2-40.2.el8.x86_64
glusterfs-libs-debuginfo-3.12.2-40.2.el8.x86_64
glusterfs-devel-3.12.2-40.2.el8.x86_64
glusterfs-cli-debuginfo-3.12.2-40.2.el8.x86_64
glusterfs-debugsource-3.12.2-40.2.el8.x86_64
glusterfs-client-xlators-3.12.2-40.2.el8.x86_64
glusterfs-fuse-3.12.2-40.2.el8.x86_64
glusterfs-cli-3.12.2-40.2.el8.x86_64

Comment 1 Niels de Vos 2019-06-14 11:19:23 UTC
glusterfs-cli has been incorrectly marked as server-only component. It is still useful for clients that run vdsm, nagios or other management/monitoring solutions that use `gluster --remote-host=...` commands.

Comment 2 Worker Ant 2019-06-14 11:21:11 UTC
REVIEW: https://review.gluster.org/22868 (build: always build glusterfs-cli to allow monitoring/managing from clients) posted (#2) for review on master by Niels de Vos

Comment 3 Sunil Kumar Acharya 2019-06-14 12:02:33 UTC
*** Bug 1720620 has been marked as a duplicate of this bug. ***

Comment 4 Worker Ant 2019-06-15 03:57:58 UTC
REVIEW: https://review.gluster.org/22868 (build: always build glusterfs-cli to allow monitoring/managing from clients) merged (#4) on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.