Bug 172063 - FC build of Openoffice now too restrictive with languages
FC build of Openoffice now too restrictive with languages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Caolan McNamara
:
: 172065 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-30 07:42 EST by Chris Neville-Smith
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.1-143.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 04:15:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Neville-Smith 2005-10-30 07:42:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
This is partly my fault, so I suppose I'd better request tweaking this.

I was indirectly responsible for filing bug 166755 shortly after the last Openoffice rpm was released. This problem baiscally came from the fact that the FC4 build of openoffice uses Fedora's default language settings instead of its own internal settings when setting the default language. However, the options box still gave the impression that you could change the default settings within Openoffice. Therefore, this option was disabled to avoid confusing people into  adjusting settings that didn't actually have any effect. (How you actually change the default language in Fedora Core is confusing in its own right, but that's a different story).

The problem with the change is that in the process it's disabled one of the ways of changing the language in the current document, and (as a quick glance of http://forums.fedoraforum.org/showthread.php?t=82759 will tell you) some people seem to have been using this method of changing the language. I know you can change the language by going to Format > Character > Fonts instead (which is a more more logical way of doing this), but other people don't know this.

One suggestion is that instead of freezing all the language options, you unfreeze the language selectors but keep the checkbox for "For current document only" frozen on. This would restore the lost functionality, although there is some scope for confusion with the "Default language for documents" section now being able to change anything but the default language. I've got other ideas, but I'll start with this.

Version-Release number of selected component (if applicable):
openoffice 2.0.0-3.2.1

How reproducible:
Always

Steps to Reproduce:
1. Go into Tools > Options > Language Settings > Languages
2. Attempt to change the Language.
3. Panic
  

Actual Results:  Discover the options you used to use are greyed out.

Expected Results:  Allow you to change the language for the current document, or at least point you to where you can do it.

Additional info:

I'm posting a link to fedoraforum.org, so if there's a stampede here it's my fault.
Comment 1 Caolan McNamara 2005-11-01 05:11:09 EST
I came to the same conclusion and the next rawhide build will allow the current
document language to be set while leaving the system ones as locked. If it
doesn't break anything it will be part of the next fc4 update
Comment 2 Caolan McNamara 2005-11-01 05:12:30 EST
*** Bug 172065 has been marked as a duplicate of this bug. ***
Comment 3 Gilboa Davara 2005-11-21 06:29:58 EST
Any chance of a fix making its way into FC4?

Other then that, how do I enable the Hebrew spell check, if I can't enable CTL?
(Assuming that I don't want to change my default system-wide language to Hebrew)

Gilboa
Comment 4 Gilboa Davara 2005-11-21 06:35:29 EST
Opps.. failed to see the "If it doesn't break anything it will be part of the
next fc4 update" part. Ignore my first question. (Second still remains)
Comment 5 Gilboa Davara 2005-12-06 04:59:18 EST
143 (-testing) solves the problem.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.