Bug 1720633 - Upcall: Avoid sending upcalls for invalid Inode
Summary: Upcall: Avoid sending upcalls for invalid Inode
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: upcall
Version: 6
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1718338 1720634
Blocks: 1717784 1726935 1729221
TreeView+ depends on / blocked
 
Reported: 2019-06-14 12:08 UTC by Soumya Koduri
Modified: 2019-07-11 15:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1718338
: 1729221 (view as bug list)
Environment:
Last Closed: 2019-07-05 09:19:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22873 None Merged upcall: Avoid sending notifications for invalid inodes 2019-07-05 09:19:23 UTC

Description Soumya Koduri 2019-06-14 12:08:54 UTC
+++ This bug was initially created as a clone of Bug #1718338 +++

Description of problem:

For nameless LOOKUPs, server creates a new inode which shall remain invalid until the fop is successfully processed post which it is linked to the inode table. 

But incase if there is an already linked inode for that entry, it discards that newly created inode which results in upcall notification. This may result in client being bombarded with unnecessary upcalls affecting performance if the data set is huge.

This issue can be avoided by looking up and storing the upcall context in the original linked inode (if exists), thus saving up on those extra callbacks.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2019-06-07 14:10:52 UTC ---

REVIEW: https://review.gluster.org/22840 (upcall: Avoid sending notifications for invalid inodes) posted (#1) for review on master by soumya k

Comment 1 Worker Ant 2019-06-14 12:48:34 UTC
REVIEW: https://review.gluster.org/22873 (upcall: Avoid sending notifications for invalid inodes) posted (#1) for review on release-6 by soumya k

Comment 2 Pasi Karkkainen 2019-06-24 09:55:02 UTC
Hmm.. it seems merge to 6.x branch is "blocked" due to a build failure regression?

https://review.gluster.org/#/c/glusterfs/+/22873/

Comment 3 Amar Tumballi 2019-07-05 08:06:20 UTC
It got fixed now. Good to get merged soon.

Comment 4 Worker Ant 2019-07-05 09:19:24 UTC
REVIEW: https://review.gluster.org/22873 (upcall: Avoid sending notifications for invalid inodes) merged (#6) on release-6 by hari gowtham


Note You need to log in before you can comment on or make changes to this bug.