Bug 172084 - lmissing liblapack.so and liblapack.a libraries so linking fails
lmissing liblapack.so and liblapack.a libraries so linking fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lapack (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 172503 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-30 21:29 EST by Robert K. Moniot
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-30 22:07:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert K. Moniot 2005-10-30 21:29:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
The rpm includes the following:
/usr/lib/liblapack.so.3
/usr/lib/liblapack.so.3.0
/usr/lib/liblapack.so.3.0.3
but not
/usr/lib/liblapack.a
/usr/lib/liblapack.so
which are needed for linking code that calls lapack routines.

Version-Release number of selected component (if applicable):
 lapack-3.0-30.fc4

How reproducible:
Always

Steps to Reproduce:
1. Write some code that calls the lapack routines, e.g. foo.f:
       program foo
       call dgetrf
       end

2. Compile it and link, e.g. g77 -o foo foo.f -llapack
3. 
  

Actual Results:  Linker bombs out saying "ld: cannot find -llapack".  No executable is produced.

Expected Results:  Link step should produce an executable foo.

Additional info:

Workaround for the lack of the .so library is simple: manually make a symlink to .so.3.  The lack of .a library is not easily worked around, but it is needed only if statically linking so it is not a problem unless you want to send binaries to others who don't have lapack installed.
Comment 1 Ignacio Vazquez-Abrams 2005-10-30 22:07:40 EST
Installing the accompanying -devel subpackages in order to build software has
been required for at least 7 years or so. Install the lapack-devel package.
Comment 2 Tom "spot" Callaway 2005-10-31 09:41:17 EST
To be fair, lapack has been one of the odd packages which has not historically
been doing this. I corrected it recently, because, well, it needed to be done,
but I expected to see a bug-report like this eventually.

Sorry for any temporary pain this may have caused you. By installing
lapack-devel, your issues should go away.
Comment 3 Robert K. Moniot 2005-10-31 09:54:33 EST
Tom, you are quite right.  I had assumed lapack was for development because it
had always worked that way.
Comment 4 Tom "spot" Callaway 2005-11-05 09:19:17 EST
*** Bug 172503 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.