Bug 172105 - Upgrade IEEE1394 libraries
Upgrade IEEE1394 libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dvgrab (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks: 171491
  Show dependency treegraph
 
Reported: 2005-10-31 10:35 EST by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 17:00:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Spec file for libiec61883 (1.73 KB, text/plain)
2005-11-10 12:40 EST, Matthias Saou
no flags Details
Spec file patch for libraw1394 (minor changes + pkgconfig devel req) (2.00 KB, patch)
2005-11-10 13:12 EST, Matthias Saou
no flags Details | Diff
Spec file patch for libavc1394 (update + minor and required changes) (1.94 KB, patch)
2005-11-10 13:18 EST, Matthias Saou
no flags Details | Diff
Updated librrom patch for libavc1394 0.5.1 (1.91 KB, patch)
2005-11-10 13:20 EST, Matthias Saou
no flags Details | Diff
Spec file patch for libdv (update to 0.104 + cleanups) (2.12 KB, patch)
2005-11-10 13:28 EST, Matthias Saou
no flags Details | Diff
Spec file patch for dvgrab (update to 2.0 + spec file cleanups) (1.41 KB, patch)
2005-11-10 13:43 EST, Matthias Saou
no flags Details | Diff

  None (edit)
Description Warren Togami 2005-10-31 10:35:56 EST
Warren needs to upgrade all of the IEEE1394 libraries in rawhide.
Comment 1 Matthias Saou 2005-11-10 12:39:52 EST
How about also including libiec61883? I'll attach the spec file I've create for
it about a month ago (it compiles, and stuff compiles against it, but I haven't
tested it entirely).

Having a DV camcoder I often use, I'm really interested in these updates, so I
may have a go at it if no one else does before I do.
Comment 2 Matthias Saou 2005-11-10 12:40:37 EST
Created attachment 120891 [details]
Spec file for libiec61883
Comment 3 Matthias Saou 2005-11-10 13:12:57 EST
Created attachment 120894 [details]
Spec file patch for libraw1394 (minor changes + pkgconfig devel req)
Comment 4 Matthias Saou 2005-11-10 13:18:55 EST
Created attachment 120895 [details]
Spec file patch for libavc1394 (update + minor and required changes)
Comment 5 Matthias Saou 2005-11-10 13:20:01 EST
Created attachment 120896 [details]
Updated librrom patch for libavc1394 0.5.1
Comment 6 Matthias Saou 2005-11-10 13:28:54 EST
Created attachment 120897 [details]
Spec file patch for libdv (update to 0.104 + cleanups)
Comment 7 Warren Togami 2005-11-10 13:31:51 EST
http://cvs.fedora.redhat.com/viewcvs/devel/libiec61883/
libiec61883 has been in FC5 for a while now.  Thanks for the other patches, I'll
start building now.
Comment 8 Matthias Saou 2005-11-10 13:43:48 EST
Created attachment 120898 [details]
Spec file patch for dvgrab (update to 2.0 + spec file cleanups)
Comment 9 Matthias Saou 2005-11-10 13:48:37 EST
(In reply to comment #7)
> libiec61883 has been in FC5 for a while now.

Well, a quick look shows that it's at least missing "libraw1394-devel >= 1.2.0"
(and IMHO "pkgconfig" too) as a dependency for the devel sub-package.
The "Group:" is non standard, it has a useless 'export CFLAGS="%{optflags}"'.

It does split off the tools in a "utils" sub-package, that's a good thing.
Comment 10 Warren Togami 2005-11-11 17:00:28 EST
libdv-0.104 wont build on x86_64 Bug #147311
Comment 11 Matthias Saou 2005-11-12 13:36:07 EST
That bug entry links to a patch... I'll try to have a look and test it for
x86_64 on Monday.
Comment 12 Warren Togami 2006-01-13 13:50:43 EST
ping matthias
Comment 13 Matthias Saou 2006-01-25 05:13:03 EST
Haven't looked at the libdv on x86_64 issue yet, but have tested my DV camcorder
on FC development (post FC5test2), and here are the results :

- Plug in the camcorder, dmesg says :
ieee1394: Node changed: 0-00:1023 -> 0-01:1023
ieee1394: Node added: ID:BUS[0-00:1023]  GUID[0800460104142508]
But no /dev/*1394* files get created, and only the default ohci1394 and ieee1394
are still loaded.

- Manually modprobe raw1394, dmesg says :
ieee1394: raw1394: /dev/raw1394 device initialized
And I now have the required /dev entry properly created :
# ls -l /dev/*1394*
crw------- 1 dude root 171, 0 Jan 24 23:54 /dev/raw1394

- From there dvgrab works! (so kino, cinelerra etc. should too)

The problem here is that the raw1394 module wasn't loaded automatically when the
camcorder was plugged in, so things won't go smoothly for end users. What Fedora
Core component should this be filed as a bug against?

Now, I'll try to rebuild libdv+patch on x86_64 and try it out this evening at
home with the camcorder again.
Comment 14 Stefan Richter 2006-02-14 14:43:55 EST
Does http://www.linux1394.org/faq.php#udev help with the device creation problem?
Comment 15 Matthias Saou 2006-02-15 13:19:34 EST
Possibly... I'll ping the fedora-devel list to see what people think there.
Comment 16 Matthias Saou 2006-02-15 13:22:34 EST
Oops, sorry! The /dev entry creation works for me (it doesn't for you)? My last
problem is the automatic loading of the modules when the DV camera is plugged in.
Comment 17 Matthias Saou 2006-02-16 08:01:42 EST
Please see bug #147311 for the libdv 0.104 update (tested and working on x86_64
and i386!).
Comment 18 Stefan Richter 2006-02-16 11:50:26 EST
Re comment #16: Everything works fine for me since I'm actually neither using FC
nor DV. I merely visited bugzilla.redhat.com because of an unrelated bug in the
kernel's IEEE 1394 subsystem and accidentally came across this bug entry.

I am not up to date which facility a distro like FC uses for automatic loading
of driver modules. However the ieee1394 base driver generates hotplug events for
hotplug scripts or udev scripts. The userspace helpers are called with these
environment variables set: VENDOR_ID, MODEL_ID, GUID, SPECIFIER_ID, VERSION, and
MODALIAS. (MODALIAS was added in Linux 2.6.14.) The userspace helpers may either
evaluate the new MODALIAS which is generated like this:
	snprintf(buf, sizeof(buf), "ieee1394:ven%08Xmo%08Xsp%08Xver%08X",
			ud->vendor_id,
			ud->model_id,
			ud->specifier_id,
			ud->version);
	PUT_ENVP("MODALIAS=%s", buf);
or directly SPECIFIER_ID and VERSION. IEEE 1394 high-level drivers match the
following specifier IDs and versions:

driver   :   specifier ID   :   version
eth1394   :   0x00005e   :   0x000001
dv1394   :   0x00a02d   :   0x010001
raw1394   :   0x00a02d   :   0x010001
raw1394   :   0x00a02d   :   0x000100
raw1394   :   0x00a02d   :   0x000101
raw1394   :   0x00a02d   :   0x000102
video1394   :   0x00a02d   :   0x000100
video1394   :   0x00a02d   :   0x000101
video1394   :   0x00a02d   :   0x000102
sbp2   :   0x00609e   :   0x010483

Note: dv1394 will soon be deprecated due to availability of libraw1394 clients
with comparable functionality. dv1394 will be removed from the kernel at some point.
Comment 19 Warren Togami 2006-03-07 17:00:46 EST
Thanks to Matthias Saou upgrading all libraries in FC5 is now done.  Please open
new bugs if you have trouble with those libraries.

Note You need to log in before you can comment on or make changes to this bug.