Bug 172107 - Kernel fails to boot with MPT Fusion
Kernel fails to boot with MPT Fusion
Status: CLOSED DUPLICATE of bug 169610
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-31 10:56 EST by Chris Lalancette
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 19:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2005-10-31 10:56:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
After installing the kernel 2.6.13-1.1532_FC4 rpm and rebooting, the kernel fails to successfully start the MPT Fusion driver (both UP and SMP).  The kernel starts, loads the MPT Fusion driver (I verified that it was in the initrd), but then fails to find any drives attached (which, in turn, causes it to fail to find / and fail switchroot).  This works fine in 2.6.11-1.1369_FC4.  I also heard from a co-worker (though I did not confirm) that this was a problem with the previous 2.6.13 kernel as well.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4

How reproducible:
Always

Steps to Reproduce:
1.  Install machine with FC4
2.  yum update to get the latest kernel version (2.6.13-1.1532_FC4)
3.  Reboot to the new kernel
  

Actual Results:  MPT Fusion driver did not find any disks attached.  Kernel boot failed with:

mkrootdev: label /1 not found
mount: error 2 mounting ext3
Switching to new root
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
unmounting old /proc
unmounting old /sys
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!


Expected Results:  MPT Fusion driver should find attached SCSI disks, and successfully switchroot to / partition.

Additional info:

Hardware:

Dell Precision 450
LSI Logic / Symbios Logic 53c1030 PCI-X Fusion MPT Dual Ultra320 SCSI (rev 07)
Seagate ST373454LW hard drive
Comment 1 Dave Jones 2005-11-04 19:53:27 EST

*** This bug has been marked as a duplicate of 169610 ***

Note You need to log in before you can comment on or make changes to this bug.