Bug 172148 - openoffice.org crashes when fetching help
openoffice.org crashes when fetching help
Status: CLOSED DUPLICATE of bug 172940
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-31 15:45 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 04:53:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2005-10-31 15:45:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
In the openoffice.org help, I tried to read about macros;organizing
and got the following crash.

0x7ac5028: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e028
0x7ac57ee: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e7ee
0xdcd420:  + 0x420 (__kernel_sigreturn + 0x0)
0x6c1888: /lib/libc.so.6 + 0x29888 (abort + 0xf8)
0xae18ba49: /usr/lib/libgcj.so.6 + 0x701a49 (_Jv_Throw + 0x51)
0xae1802e6: /usr/lib/libgcj.so.6 + 0x6f62e6 (_Jv_NewPrimArray + 0x0)
0xae17efa8: /usr/lib/libgcj.so.6 + 0x6f4fa8
0x288990: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xe4990
0x28a09d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xe609d (OutputDevice::DrawRect(Rectangle const&) + 0xc5)
0x2a75b4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1035b4
0x2a9c90: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x105c90
0x2a9cf5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x105cf5 (OutputDevice::Erase() + 0x59)
0x2aa764: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x106764
0x2aabd0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x106bd0 (VirtualDevice::VirtualDevice(unsigned short) + 0x4e)
0x115794a: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x32994a
0x113c223: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x30e223
0x1157a5c: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x329a5c
0x13aeea3: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x580ea3 (SwDocShell::UpdateFontList() + 0x47)
0x13aef3b: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x580f3b
0x13affa7: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x581fa7
0x1eee391: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x11e391 (SfxObjectShell::DoLoad(SfxMedium*) + 0x4ef)
0x1f1d2d9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x14d2d9 (SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 0x2f9)
0x1f38fa7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x168fa7
0x59d7c1b: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe0c1b
0x59d7dd9: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe0dd9
0x59d7e92: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe0e92
0x5941d06: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4ad06
0x1eacb43: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xdcb43
0x1eacebb: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xdcebb
0x1eacf02: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xdcf02
0x1e672ce: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x972ce
0x1ea667e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xd667e
0x363b23: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1bfb23 (Window::Notify(NotifyEvent&) + 0x3a7)
0x363b23: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1bfb23 (Window::Notify(NotifyEvent&) + 0x3a7)
0x37e2c7: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1da2c7 (Control::Notify(NotifyEvent&) + 0x87)
0x35b628: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1b7628 (Window::KeyInput(KeyEvent const&) + 0x2a)
0x388b72: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1e4b72 (Edit::KeyInput(KeyEvent const&) + 0x34)
0x370515: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cc515
0x371ecb: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cdecb
0x28c1a88: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28a88
0x28bfb8b: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x26b8b
0x28c0f09: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x27f09
0x7720be2: /usr/lib/libgtk-x11-2.0.so.0 + 0x10bbe2
0x290d285: /usr/lib/libgobject-2.0.so.0 + 0x8285 (g_closure_invoke + 0x10a)
0x291b75b: /usr/lib/libgobject-2.0.so.0 + 0x1675b
0x291cc23: /usr/lib/libgobject-2.0.so.0 + 0x17c23 (g_signal_emit_valist + 0x41e)
0x291d223: /usr/lib/libgobject-2.0.so.0 + 0x18223 (g_signal_emit + 0x29)
0x77fc743: /usr/lib/libgtk-x11-2.0.so.0 + 0x1e7743
0x771f459: /usr/lib/libgtk-x11-2.0.so.0 + 0x10a459 (gtk_propagate_event + 0x1d2)
0x771f784: /usr/lib/libgtk-x11-2.0.so.0 + 0x10a784 (gtk_main_do_event + 0x329)
0x7d6ddf6: /usr/lib/libgdk-x11-2.0.so.0 + 0x3bdf6
0x67174ce: /usr/lib/libglib-2.0.so.0 + 0x234ce (g_main_context_dispatch + 0x1dc)
0x671a4d6: /usr/lib/libglib-2.0.so.0 + 0x264d6
0x671a9b8: /usr/lib/libglib-2.0.so.0 + 0x269b8 (g_main_context_iteration + 0x66)
0x28b1bcf: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18bcf
0x52c2afa: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45afa (X11SalInstance::Yield(unsigned char) + 0x28)
0x2243b4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x803b4 (Application::Yield() + 0x48)
0x2243ea: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x803ea (Application::Execute() + 0x26)
0xe06d73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20d73 (desktop::Desktop::Main() + 0x15ab)
0x2297bf: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x857bf
0x22986f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8586f (SVMain() + 0x29)
0xe01bd7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1bbd7 (sal_main + 0x57)
0xe01c23: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1bc23 (main + 0x27)
0x6acd5f: /lib/libc.so.6 + 0x14d5f (__libc_start_main + 0xdf)
0x80484e1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4e1


Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.0-3.2.1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.Open the help tool
2.Go to macros;organizing
3.
  

Additional info:
Comment 1 Caolan McNamara 2005-11-01 05:16:16 EST
There's some gcj in that stack, but I don't think the help system uses java, and
I don't see the help libs in the stack. Might not be the help itself that
actually crashed. Did you have anything else going on at the time, e.g. some
sample OOo java example components running or anything ?
Comment 2 Anthony Green 2005-11-01 07:28:05 EST
(In reply to comment #1)
> There's some gcj in that stack, but I don't think the help system uses java, and
> I don't see the help libs in the stack. Might not be the help itself that
> actually crashed. Did you have anything else going on at the time, e.g. some
> sample OOo java example components running or anything ?

I think I had some Organize Macros dialog open, which fires up java.
I'll see if I can reproduce.
Comment 3 Caolan McNamara 2005-11-04 04:20:20 EST
Personally I'm real suspicious of < gcc 4.0.2, e.g. I'm not sure if 
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=22132 
is lurking still in 4.0.1, if so I think pretty much anything could be happening :-(
Comment 4 Caolan McNamara 2005-11-14 04:53:12 EST
This has got to be an icu problem, layouting from corrupt character layout data
which would explain all, always in the OutputDevice rendering area and intermittent

*** This bug has been marked as a duplicate of 172940 ***

Note You need to log in before you can comment on or make changes to this bug.