Bug 172940 - openoffice write crash while typing in simple text (crash dump)
openoffice write crash while typing in simple text (crash dump)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 172148 173227 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 09:51 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-18 08:09:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-11-11 09:51:30 EST
Description of problem:
0x70ef8a5: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e8a5
0x70f00a8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f0a8
0xfa3420:  + 0x420 (__kernel_sigreturn + 0x0)
0x7373cd4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xeecd4
0x73753d9: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xf03d9
(OutputDevice::DrawRect(Rectangle const&) + 0xc5)
0x7393b2c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10eb2c
0x73961ea: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1111ea
0x739624f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x11124f
(OutputDevice::Erase() + 0x59)
0x7396cc0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x111cc0
0x739712c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x11212c
(VirtualDevice::VirtualDevice(unsigned short) + 0x4e)
0x279b6b6: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x4d66b6
0x284859b: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x58359b
(SdrPageViewWindow::CreateViewSpecificObjectContact() + 0x27)
0x28485d6: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x5835d6
(SdrPageViewWindow::GetObjectContact() const + 0x1e)
0x284b65b: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x58665b
(SdrPageViewWindow::Redraw(Region const&, unsigned short, unsigned char const*,
sdr::contact::ViewObjectContactRedirector*) const + 0x30f)
0x284b7f8: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x5867f8
(SdrPageView::DrawLayer(unsigned char, Rectangle const&, OutputDevice*, unsigned
short) const + 0xae)
0x300757a: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1cd57a
0x30eee7d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b4e7d
0x300ae1f: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1d0e1f
(ViewShell::ImplEndAction(unsigned char) + 0x5b5)
0x2fe649d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1ac49d
0x2fee936: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1b4936
(SwCrsrShell::EndAction(unsigned char) + 0x7a)
0x2fe6312: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1ac312
(SwEditShell::EndAllAction() + 0x30)
0x2fdceb8: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1a2eb8
(SwEditShell::Insert(String const&) + 0x13e)
0x350dfc8: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x6d3fc8
(SwWrtShell::Insert(String const&) + 0x220)
0x343a62d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x60062d
0x3443a2a: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x609a2a
0x745f1aa: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1da1aa
0x7460dec: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1dbdec
0xe1feae: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28eae
0xe1e074: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x27074
0xe1edf8: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x27df8
0x9d8a33: /usr/lib/libgobject-2.0.so.0 + 0x14a33
(g_cclosure_marshal_VOID__STRING + 0x53)
0x9ccbd8: /usr/lib/libgobject-2.0.so.0 + 0x8bd8 (g_closure_invoke + 0x11e)
0x9db213: /usr/lib/libgobject-2.0.so.0 + 0x17213
0x9dc850: /usr/lib/libgobject-2.0.so.0 + 0x18850 (g_signal_emit_valist + 0x6ab)
0x9df47f: /usr/lib/libgobject-2.0.so.0 + 0x1b47f (g_signal_emit_by_name + 0xf0)
0x6dee161: /usr/lib/libgtk-x11-2.0.so.0 + 0xfc161
0x9d8a33: /usr/lib/libgobject-2.0.so.0 + 0x14a33
(g_cclosure_marshal_VOID__STRING + 0x53)
0x9ccbd8: /usr/lib/libgobject-2.0.so.0 + 0x8bd8 (g_closure_invoke + 0x11e)
0x9db213: /usr/lib/libgobject-2.0.so.0 + 0x17213
0x9dc850: /usr/lib/libgobject-2.0.so.0 + 0x18850 (g_signal_emit_valist + 0x6ab)
0x9df47f: /usr/lib/libgobject-2.0.so.0 + 0x1b47f (g_signal_emit_by_name + 0xf0)
0x6dec458: /usr/lib/libgtk-x11-2.0.so.0 + 0xfa458
0x6decab6: /usr/lib/libgtk-x11-2.0.so.0 + 0xfaab6
0x6debd76: /usr/lib/libgtk-x11-2.0.so.0 + 0xf9d76
(gtk_im_context_filter_keypress + 0x4d)
0x6dedef0: /usr/lib/libgtk-x11-2.0.so.0 + 0xfbef0
0x6debd76: /usr/lib/libgtk-x11-2.0.so.0 + 0xf9d76
(gtk_im_context_filter_keypress + 0x4d)
0xe1f50c: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x2850c
0xe1f608: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28608
0x6e080cc: /usr/lib/libgtk-x11-2.0.so.0 + 0x1160cc
0x9ccbd8: /usr/lib/libgobject-2.0.so.0 + 0x8bd8 (g_closure_invoke + 0x11e)
0x9db213: /usr/lib/libgobject-2.0.so.0 + 0x17213
0x9dc5c3: /usr/lib/libgobject-2.0.so.0 + 0x185c3 (g_signal_emit_valist + 0x41e)
0x9dcbc3: /usr/lib/libgobject-2.0.so.0 + 0x18bc3 (g_signal_emit + 0x29)
0x6eea4ff: /usr/lib/libgtk-x11-2.0.so.0 + 0x1f84ff
0x6e06919: /usr/lib/libgtk-x11-2.0.so.0 + 0x114919 (gtk_propagate_event + 0x1d3)
0x6e06c40: /usr/lib/libgtk-x11-2.0.so.0 + 0x114c40 (gtk_main_do_event + 0x325)
0x9186f3: /usr/lib/libgdk-x11-2.0.so.0 + 0x3e6f3
0xc35a50: /usr/lib/libglib-2.0.so.0 + 0x24a50 (g_main_context_dispatch + 0x1dc)
0xc38a66: /usr/lib/libglib-2.0.so.0 + 0x27a66
0xc38f48: /usr/lib/libglib-2.0.so.0 + 0x27f48 (g_main_context_iteration + 0x66)
0xe0ff23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18f23
0xe74852: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46852
(X11SalInstance::Yield(unsigned char) + 0x28)
0x730e34c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8934c
(Application::Yield() + 0x48)
0x730e382: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x89382
(Application::Execute() + 0x26)
0xaee7ba: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x257ba
(desktop::Desktop::Main() + 0x15b0)
0x7313747: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e747
0x73137f7: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e7f7 (SVMain()
+ 0x29)
0xae605f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d05f (sal_main +
0x57)
0xae60ab: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d0ab (main + 0x27)
0x78250f: /lib/libc.so.6 + 0x1550f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4c5


Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.1-0.138.3.2
kernel-2.6.14-1.1660_FC5

How reproducible:
Not sure, but this one happened quickly after opeing the doc. I had another
oowriter crash yesterday for no apparent reason on an x86_64 machine.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
never crash

Additional info:
Comment 1 Robin Laing 2005-11-13 02:57:33 EST
Is this bug related to 171873?  OpenOffice crashing?
Comment 2 John Ellson 2005-11-13 03:16:09 EST
Can't tell for sure, but probably.   I did not have assistive_technology_support
enabled at the time of the crash. 
Comment 3 Caolan McNamara 2005-11-14 04:44:02 EST
Seems to be icu related, should be fixed > 2.0.1-0.139.1
Comment 4 Caolan McNamara 2005-11-14 04:53:19 EST
*** Bug 172148 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2005-11-15 07:24:54 EST
*** Bug 173227 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.