Bug 1722030 - RxCpp: FTBFS due to change path of hardlink
Summary: RxCpp: FTBFS due to change path of hardlink
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: RxCpp
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
: 1734913 1735433 (view as bug list)
Depends On:
Blocks: F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-06-19 12:02 UTC by Jitka Plesnikova
Modified: 2019-08-15 09:01 UTC (History)
2 users (show)

Fixed In Version: RxCpp-4.1.0-4.fc32 RxCpp-4.1.0-4.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-15 09:01:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Jitka Plesnikova 2019-06-19 12:02:15 UTC
Description of problem:
Package RxCpp fails to build from source in Fedora rawhide with error:

+ /usr/sbin/hardlink -fv /builddir/build/BUILDROOT/RxCpp-4.1.0-2.fc31.x86_64/usr/share/doc/RxCpp
BUILDSTDERR: /var/tmp/rpm-tmp.rFQGdb: line 47: /usr/sbin/hardlink: No such file or directory

It is caused, because hardlink was merged to unix-linux and the path was changed from
/usr/sbin/hardlink
to
/usr/bin/hardlink

Version-Release number of selected component (if applicable):
4.1.0-2.fc30

Steps to Reproduce:
koji build --scratch f31 RxCpp-4.1.0-2.fc30.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/RxCpp

Comment 1 Ben Cotton 2019-08-13 19:10:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 2 Jitka Plesnikova 2019-08-15 08:58:10 UTC
*** Bug 1735433 has been marked as a duplicate of this bug. ***

Comment 3 Jitka Plesnikova 2019-08-15 08:58:13 UTC
*** Bug 1734913 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.