Bug 1722507 - Incorrect reporting of type/gfid mismatch
Summary: Incorrect reporting of type/gfid mismatch
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1715447 1729481
TreeView+ depends on / blocked
 
Reported: 2019-06-20 13:54 UTC by Karthik U S
Modified: 2019-07-12 11:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1729481 (view as bug list)
Environment:
Last Closed: 2019-07-12 10:43:05 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22908 None Merged cluster/afr: Fix incorrect reporting of gfid & type mismatch 2019-07-12 10:43:04 UTC

Description Karthik U S 2019-06-20 13:54:30 UTC
Description of problem:

When checking for type and gfid mismatch, if the type or gfid is unknown because of missing gfid handle and the gfid xattr, it will be reported as type or gfid mismatch and the heal will not complete.

Comment 1 Worker Ant 2019-06-20 14:04:31 UTC
REVIEW: https://review.gluster.org/22908 (cluster/afr: Fix incorrect reporting of gfid & type mismatch) posted (#1) for review on master by Karthik U S

Comment 2 Worker Ant 2019-07-12 10:43:05 UTC
REVIEW: https://review.gluster.org/22908 (cluster/afr: Fix incorrect reporting of gfid & type mismatch) merged (#4) on master by Pranith Kumar Karampuri


Note You need to log in before you can comment on or make changes to this bug.