Bug 1729481 - Incorrect reporting of type/gfid mismatch
Summary: Incorrect reporting of type/gfid mismatch
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On: 1722507
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 11:37 UTC by Karthik U S
Modified: 2019-07-20 07:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1722507
Environment:
Last Closed: 2019-07-20 07:36:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 23036 0 None Merged cluster/afr: Fix incorrect reporting of gfid & type mismatch 2019-07-20 07:36:17 UTC

Description Karthik U S 2019-07-12 11:37:34 UTC
+++ This bug was initially created as a clone of Bug #1722507 +++

Description of problem:

When checking for type and gfid mismatch, if the type or gfid is unknown because of missing gfid handle and the gfid xattr, it will be reported as type or gfid mismatch and the heal will not complete.

Comment 1 Worker Ant 2019-07-12 11:46:21 UTC
REVIEW: https://review.gluster.org/23036 (cluster/afr: Fix incorrect reporting of gfid & type mismatch) posted (#1) for review on release-7 by Karthik U S

Comment 2 Worker Ant 2019-07-20 07:36:18 UTC
REVIEW: https://review.gluster.org/23036 (cluster/afr: Fix incorrect reporting of gfid & type mismatch) merged (#2) on release-7 by Rinku Kothiya


Note You need to log in before you can comment on or make changes to this bug.