Bug 172335 - X server locks entire machine with Radeon X600
X server locks entire machine with Radeon X600
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-02 16:47 EST by James Ralston
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 07:02:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log from a session that locks (55.58 KB, text/plain)
2005-11-02 16:47 EST, James Ralston
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5853 None None None Never

  None (edit)
Description James Ralston 2005-11-02 16:47:00 EST
Description of problem:

I've installed FC4 (and all current package updates) on a Dell Optiplex GX620. 
This machine has a Radeon X600 card installed in the PEG slot.  It has 2GB of
DDR2 PC2-5300 memory (4 512MB DIMMs).  Since it's an Intel EM64T, I installed
the x86_64 edition of FC4.

(I initially encountered problems while trying to use the DVI output with a Dell
LCD Display, but that's a known bug with the default mode timings.  Once I
switched to the VGA connector, I was fine.)

The specific problem I am having now is that starting X locks the entire
machine, hard.  And when I say "lock", I mean "the machine even stops responding
to ICMP ECHO requests".  Curiously, though, I get as far as the Fedora splash
screen before it locks.

Every attempt to start X has locked in this manner--even running
system-config-display.  The machine is otherwise fast and rock-solid stable;
it's been up and running for a week or so without any problems whatsoever.

The radeon(4) man page states that the Radeon X600 is supported.  From the
Xorg.0.log, the X server has no difficulty recognizing both the card and the
monitor attached to it.  I can detect no other problems with the machine.  I
don't understand why it consistently locks.

Version-Release number of selected component (if applicable):

xorg-x11-6.8.2-37.FC4.49.2
kernel-smp-2.6.13-1.1532_FC4

How reproducible:

The easiest way to reproduce the problem is to boot the x86_64 installation
CD/DVD in graphical install mode.  After anaconda starts the X server, you'll
get the all-white screen with the mouse pointer on it.  It'll lock after about 5
seconds or so.
  
Actual results:

The entire system locks.

Expected results:

Success.

Additional info:

I've also tested these distributions:

FC4 (i386)
RHEL 4AS U1 (x86_64)

The X server locks in exactly the same manner.
Comment 1 James Ralston 2005-11-02 16:47:00 EST
Created attachment 120661 [details]
X server log from a session that locks
Comment 2 James Ralston 2005-11-02 18:27:39 EST
Based on bug #138539, I tried disabling hyperthreading and booting with the
non-SMP kernel.  It still locks.

I then tried disabling DRI (still using the non-SMP kernel without
hyperthreading).  It still locks.
Comment 3 Trond H. Amundsen 2006-01-09 11:56:32 EST
FWIW, I have the same problem with a GX620 running RHEL4U2. I reported this and
it's known to the world as bug #176826.
Comment 4 Mike A. Harris 2006-02-01 03:33:18 EST
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 5 Mike A. Harris 2006-02-09 08:19:00 EST
Closing bug due to lack of information, and lack of feedback/response.
If the issue is still present/relevent, please respond to the above
engineering queries and reopen and we will re-review the issue.

Setting status to "CANTFIX" (lack of response)
Comment 6 James Ralston 2006-02-09 16:39:43 EST
I was (finally) able to get back to this issue today.

Yes, the Radeon driver still wedges the entire machine.  This is with
kernel-2.6.15-1.1831_FC4 and xorg-x11-6.8.2-37.FC4.49.2.

Here's the bug I've opened with freedesktop.org:
https://bugs.freedesktop.org/show_bug.cgi?id=5853

(I've also added an external reference to this bug report.)
Comment 7 Mike A. Harris 2006-03-07 07:02:04 EST
Thanks, tracking in the X.Org tracker now.

Note You need to log in before you can comment on or make changes to this bug.