Bug 172510 - yum traceback after detection of conflicting package
yum traceback after detection of conflicting package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 172665 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-05 13:51 EST by Michael Cornelison
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 00:02:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cornelison 2005-11-05 13:51:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
yum crashed when I attempted a local install of hplip rpm package
(HP multifunction device driver)

software error was the following:
YumBaseCli instance has no attribute 'pkgSack'



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. using FC4 with kernel 2.6.13 (i386 uniprocessor)
2. # yum localinstall hplip-0.9.6-4.i386.rpm



Actual Results:  Here is the entire console output:

# yum localinstall hplip-0.9.6-4.i386.rpm
Setting up Local Package Process
Examining /win/m/mico/pc/linux/hplip-0.9.6-4.i386.rpm: hplip - 0.9.6-4.i386
Marking /win/m/mico/pc/linux/hplip-0.9.6-4.i386.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package hplip.i386 0:0.9.6-4 set to be updated
--> Running transaction check
--> Processing Conflict: hplip conflicts system-config-printer < 0.6.132
Traceback (most recent call last):
  File "/usr/bin/yum", line 27, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 133, in main
    (result, resultmsgs) = base.buildTransaction()
  File "__init__.py", line 339, in buildTransaction
  File "depsolve.py", line 254, in resolveDeps
  File "depsolve.py", line 682, in _processConflict
  File "__init__.py", line 281, in doUpdateSetup
AttributeError: YumBaseCli instance has no attribute 'pkgSack'


Expected Results:  Should output a list of installed packages that are incompatible and what packages (versions) are expected in their place.

Additional info:
Comment 1 Seth Vidal 2005-11-07 00:02:38 EST
Yep, this is a bug - I believe I just applied a fix to cvs which should correct it.

should be fixed in yum 2.4.1
Comment 2 Seth Vidal 2005-11-07 23:57:45 EST
*** Bug 172665 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.