Bug 172665 - yum - "no attribute 'pkgSack'" while resolving dependencies
yum - "no attribute 'pkgSack'" while resolving dependencies
Status: CLOSED DUPLICATE of bug 172510
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 19:51 EST by Michal Jaegermann
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 23:57:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-11-07 19:51:00 EST
Description of problem:

I got the following traceback from yum while it tried to resolve some
dependencies:

Traceback (most recent call last):
  File "/usr/bin/yum", line 27, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 133, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 339, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 255, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 683, in
_processConflict
    self.doUpdateSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 281, in
doUpdateSetup
    self.pkgSack.simplePkgList())
AttributeError: YumBaseCli instance has no attribute 'pkgSack'


Version-Release number of selected component (if applicable):
yum-2.4.0-8

How reproducible:
no idea - does not seem to be obvious how to do that
Comment 1 Seth Vidal 2005-11-07 23:57:29 EST

*** This bug has been marked as a duplicate of 172510 ***

Note You need to log in before you can comment on or make changes to this bug.