Bug 1726144 - [backport 4.1] must-gather gather_network_logs script does not save output under /must-gather
Summary: [backport 4.1] must-gather gather_network_logs script does not save output un...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.1.z
Assignee: Ricardo Carrillo Cruz
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On: 1726137
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-02 08:30 UTC by Ricardo Carrillo Cruz
Modified: 2019-08-28 19:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1726137
Environment:
Last Closed: 2019-08-28 19:54:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2547 None None None 2019-08-28 19:54:54 UTC
Github openshift must-gather pull 109 None None None 2019-08-20 18:05:16 UTC

Description Ricardo Carrillo Cruz 2019-07-02 08:30:54 UTC
+++ This bug was initially created as a clone of Bug #1726137 +++

Description of problem:

must-gather gather_network_logs does not set the log path to /must-gather

Version-Release number of selected component (if applicable):

4.2.0

Comment 1 zhaozhanqi 2019-07-02 08:38:16 UTC
we already bug is tracing this kind of bug 1720833, This should be duplicated, please feel free reopen it if I'm wrong.

*** This bug has been marked as a duplicate of bug 1720833 ***

Comment 2 Ricardo Carrillo Cruz 2019-07-02 08:41:30 UTC
Differrent issues.

Bug https://bugzilla.redhat.com/show_bug.cgi?id=1720833 should be closed as explained there, oc adm must-gather is not expected to collect network logs via gather_network_logs.

Comment 3 Eric Rich 2019-07-02 12:45:15 UTC
https://github.com/openshift/must-gather/pull/109 is the PR for this bug

Comment 5 Anurag saxena 2019-08-21 15:12:43 UTC
Works okay now on 4.1.0-0.nightly-2019-08-19-173358

$ oc adm must-gather --keep -- /usr/bin/gather_network_logs
Using image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:fb81ff75f555c6efa161a377602a8422a457b670a9bf9eb0cabc234624f18640
namespace/openshift-must-gather-zb9dt created
clusterrolebinding.rbac.authorization.k8s.io/must-gather-vmbfc created
WARNING: Collecting network logs on ALL nodes in your cluster. This could take a large amount of time.
INFO: Waiting for node network log collection to complete ...
INFO: Node network log collection to complete.
receiving incremental file list
created directory must-gather.local.4742960411380755217
./
network_logs/
network_logs/ip-10-0-130-38.ca-central-1.compute.internal_iptables
network_logs/ip-10-0-130-38.ca-central-1.compute.internal_ovs_dump
network_logs/ip-10-0-131-149.ca-central-1.compute.internal_iptables
network_logs/ip-10-0-131-149.ca-central-1.compute.internal_ovs_dump
network_logs/ip-10-0-135-63.ca-central-1.compute.internal_iptables
network_logs/ip-10-0-135-63.ca-central-1.compute.internal_ovs_dump
network_logs/ip-10-0-142-32.ca-central-1.compute.internal_iptables
network_logs/ip-10-0-142-32.ca-central-1.compute.internal_ovs_dump
network_logs/ip-10-0-154-184.ca-central-1.compute.internal_iptables
network_logs/ip-10-0-154-184.ca-central-1.compute.internal_ovs_dump
network_logs/ip-10-0-155-199.ca-central-1.compute.internal_iptables
network_logs/ip-10-0-155-199.ca-central-1.compute.internal_ovs_dump
network_logs/ovs-8zpbp_ovsdb_log
network_logs/ovs-8zpbp_vswitchd_log
network_logs/ovs-jbpbt_ovsdb_log
network_logs/ovs-jbpbt_vswitchd_log
network_logs/ovs-krqwr_ovsdb_log
network_logs/ovs-krqwr_vswitchd_log
network_logs/ovs-qchcc_ovsdb_log
network_logs/ovs-qchcc_vswitchd_log
network_logs/ovs-smg4l_ovsdb_log
network_logs/ovs-smg4l_vswitchd_log
network_logs/ovs-x425l_ovsdb_log
network_logs/ovs-x425l_vswitchd_log
.
.


$ ls -l network_logs/
total 408
-rw-r--r--. 1 core core 42747 Aug 21 15:04 ip-10-0-130-38.ca-central-1.compute.internal_iptables
-rw-r--r--. 1 core core  1584 Aug 21 15:04 ip-10-0-130-38.ca-central-1.compute.internal_ovs_dump
-rw-r--r--. 1 core core 42943 Aug 21 15:04 ip-10-0-131-149.ca-central-1.compute.internal_iptables
-rw-r--r--. 1 core core  1129 Aug 21 15:04 ip-10-0-131-149.ca-central-1.compute.internal_ovs_dump
-rw-r--r--. 1 core core 42731 Aug 21 15:04 ip-10-0-135-63.ca-central-1.compute.internal_iptables
-rw-r--r--. 1 core core  1584 Aug 21 15:04 ip-10-0-135-63.ca-central-1.compute.internal_ovs_dump
-rw-r--r--. 1 core core 42756 Aug 21 15:04 ip-10-0-142-32.ca-central-1.compute.internal_iptables
-rw-r--r--. 1 core core   869 Aug 21 15:04 ip-10-0-142-32.ca-central-1.compute.internal_ovs_dump
-rw-r--r--. 1 core core 42952 Aug 21 15:04 ip-10-0-154-184.ca-central-1.compute.internal_iptables
-rw-r--r--. 1 core core   869 Aug 21 15:04 ip-10-0-154-184.ca-central-1.compute.internal_ovs_dump
-rw-r--r--. 1 core core 42918 Aug 21 15:04 ip-10-0-155-199.ca-central-1.compute.internal_iptables
-rw-r--r--. 1 core core  1324 Aug 21 15:04 ip-10-0-155-199.ca-central-1.compute.internal_ovs_dump
-rw-r--r--. 1 core core   361 Aug 21 15:04 ovs-8zpbp_ovsdb_log
-rw-r--r--. 1 core core  8101 Aug 21 15:04 ovs-8zpbp_vswitchd_log
-rw-r--r--. 1 core core  1413 Aug 21 15:04 ovs-jbpbt_ovsdb_log
-rw-r--r--. 1 core core 19576 Aug 21 15:04 ovs-jbpbt_vswitchd_log
-rw-r--r--. 1 core core  3409 Aug 21 15:04 ovs-krqwr_ovsdb_log
-rw-r--r--. 1 core core 24354 Aug 21 15:04 ovs-krqwr_vswitchd_log
-rw-r--r--. 1 core core  2970 Aug 21 15:04 ovs-qchcc_ovsdb_log
-rw-r--r--. 1 core core 25468 Aug 21 15:04 ovs-qchcc_vswitchd_log
-rw-r--r--. 1 core core   939 Aug 21 15:04 ovs-smg4l_ovsdb_log
-rw-r--r--. 1 core core  6935 Aug 21 15:04 ovs-smg4l_vswitchd_log
-rw-r--r--. 1 core core   361 Aug 21 15:04 ovs-x425l_ovsdb_log
-rw-r--r--. 1 core core  6828 Aug 21 15:04 ovs-x425l_vswitchd_log

Comment 7 errata-xmlrpc 2019-08-28 19:54:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547


Note You need to log in before you can comment on or make changes to this bug.