Bug 1720833 - [backport 4.1] network collection scripts to must-gather
Summary: [backport 4.1] network collection scripts to must-gather
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.z
Assignee: Ricardo Carrillo Cruz
QA Contact: zhaozhanqi
URL:
Whiteboard: 4.1.9
: 1724746 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-15 14:02 UTC by Eric Rich
Modified: 2019-08-07 15:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-07 15:06:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2010 None None None 2019-08-07 15:06:06 UTC

Description Eric Rich 2019-06-15 14:02:15 UTC
Description of problem: backport https://github.com/openshift/must-gather/pull/94

https://jira.coreos.com/browse/SDN-428

Comment 1 Eric Rich 2019-06-15 14:44:21 UTC
https://github.com/openshift/must-gather/pull/101 is tracking this.

Comment 3 zhaozhanqi 2019-06-27 07:09:33 UTC
using the latest 4.1 nightly build 4.1.0-0.nightly-2019-06-26-044128

when using `oc adm must-gather` , did not find the network related information.

Comment 4 zhaozhanqi 2019-06-28 01:03:27 UTC
*** Bug 1724746 has been marked as a duplicate of this bug. ***

Comment 7 zhaozhanqi 2019-07-01 06:42:29 UTC
hi, I tried this issue on 4.1.0-0.nightly-2019-06-27-204847 and 4.1.0-0.nightly-2019-06-30-214248. Both of them are not fixed this bug.

from https://github.com/openshift/must-gather/pull/101/files,  it's using 'must-gather' as the folder. but when run 'oc adm must-gather', it will create random folder like named 'must-gather.local.4807231115650811082', I'm not sure if it causes the issue.

FYI. it can work if I run this shell script 'https://raw.githubusercontent.com/openshift-cherrypick-robot/must-gather/1638ec49bc976a65c3f41bc5d5ce3b8bc2813959/collection-scripts/gather_network_logs' separately.

Comment 8 Eric Rich 2019-07-01 15:26:03 UTC
(In reply to zhaozhanqi from comment #7)
> 
> FYI. it can work if I run this shell script
> 'https://raw.githubusercontent.com/openshift-cherrypick-robot/must-gather/
> 1638ec49bc976a65c3f41bc5d5ce3b8bc2813959/collection-scripts/
> gather_network_logs' separately.

The script is not run by default! So running it separately is how this should be tested.

Comment 9 Ricardo Carrillo Cruz 2019-07-01 15:35:17 UTC
The 'gather_network_logs' script is not invoked on 'gather', which is the
script run by 'oc adm must-gather'. That is due to gather_network_logs
is expected to consume a list of nodes, instead of been a general collection script.

In looking by this I saw a tangential issue, the 'gather_network_logs' won't create
correctly /must-gather, check PR https://github.com/openshift/must-gather/pull/108 .

Comment 11 zhaozhanqi 2019-07-02 08:38:16 UTC
*** Bug 1726144 has been marked as a duplicate of this bug. ***

Comment 13 zhaozhanqi 2019-07-31 04:35:57 UTC
Verified this bug on 4.1.0-0.nightly-2019-07-29-171515 with command:

oc adm must-gather --keep -- /usr/bin/gather_network_logs

Comment 15 errata-xmlrpc 2019-08-07 15:06:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2010


Note You need to log in before you can comment on or make changes to this bug.