Bug 172713 - nmbd either crashes and dies or stops responding
nmbd either crashes and dies or stops responding
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.0
i386 Linux
urgent Severity high
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
https://bugzilla.redhat.com/bugzilla/...
:
: 172714 229801 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-08 11:42 EST by Adam Thompson
Modified: 2015-01-28 05:19 EST (History)
4 users (show)

See Also:
Fixed In Version: RHEA-2007-0698
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:14:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from valgrind run (73.82 KB, text/plain)
2005-11-08 12:15 EST, Adam Thompson
no flags Details
nmbd crash / stales. (1005 bytes, patch)
2006-12-13 05:22 EST, Jose Plans
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 2215 None None None Never

  None (edit)
Description Adam Thompson 2005-11-08 11:42:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; InfoPath.1)

Description of problem:
see bug# 150582, errata does NOT fix the problem for us - please reopen

Version-Release number of selected component (if applicable):
samba-3.0.10-1.4E.2

How reproducible:
Always

Steps to Reproduce:
Start samba.  Wait less than two minutes.  Watch network browsing and WINS service die.

Additional info:
Comment 1 Jay Fenlason 2005-11-08 11:51:54 EST
have you reported this to support?  Bugs reported directly to bugzilla go to 
the bottom of the priority queue. 
 
Can you run the nmbd daemon under valgrind, and report where it failed?  I've 
been completely unable to reproduce this problem here, so we're gonna have to 
debug this on your machine. 
Comment 2 Jay Fenlason 2005-11-08 11:54:56 EST
*** Bug 172714 has been marked as a duplicate of this bug. ***
Comment 3 Adam Thompson 2005-11-08 12:14:05 EST
I haven't the faintest clue how to use valgrind properly... but took a quick 
look and have attached output from a run under script(1).
FYI - nmbd is running for maybe 30 seconds at a time right now.
Comment 4 Adam Thompson 2005-11-08 12:15:37 EST
Created attachment 120818 [details]
output from valgrind run
Comment 5 Adam Thompson 2005-11-08 12:39:27 EST
Opened new (Red Hat Contract) Service Request #720168
Comment 6 Adam Thompson 2005-11-09 12:20:11 EST
Upgraded to samba-3.0.20b-1 from www.samba.org (rebuilt from SRPM), seems to
have solved the problem.
Don't know why, don't have time to care.
Comment 7 Ole Holm Nielsen 2006-02-03 07:23:49 EST
We have been sorely bitten by this bug as well :-(
Our Microsoft Networking browse servers are exclusively Redhat RHEL3/4 servers.
We moved the SAMBA "wins server" (Domain Master Browser) function from an old
RHEL3 server to a new RHEL4-U2 (all patches installed) server
running samba-3.0.10-1.4E.2.
Immediately our Windows network browsing came to a grinding halt :-(

The last line seen in /var/log/samba/nmbd.log is:
*** glibc detected *** free(): invalid next size (fast): 0x09023558 ***
and although the nmbd process is still running, nmbd has ceased responding
to "smbclient -L <servername>".

This seems to be the same bug as reported in 150583 and 150582 almost one
year ago.

We're greatly surprised that such a fundamental bug in SAMBA functionality
(remember, we're an RHEL only shop, no MS-Windows servers here) has
been allowed to exist through several versions of RHEL4.

Could you please advise: Should we uninstall Redhat's SAMBA RPMs and 
switch to the SAMBA 3.0.21b RPM from samba.org (and become responsible ourselves
for updating SAMBA manually), or can we expect a timely bug fix from Redhat ?

I also reported this on Bug 150582, but that bug was unfortunately closed.
Comment 8 John Smith 2006-02-13 05:46:15 EST
Using samba-3.0.10-1.4E.2

i can get around this error via switching off "wins proxy" - however i need its
functionality.
Comment 9 John Smith 2006-02-13 09:51:10 EST
And i can verify that upgrading to samba.org packages helps.
Comment 10 Ole Holm Nielsen 2006-03-06 02:55:28 EST
We got tired of waiting for Redhat to fix the Samba bug in RHEL4, and we *need* a 
working Samba WINS server, so we decided to uninstall the Redhat Samba RPMs and 
build our own from samba.org's samba-3.0.21b source.

In the Samba source tree we go to packaging/RHEL and run makerpms.sh
in order to build drop-in replacements for the Redhat RPMs.

We can now report that samba-3.0.21b works without a glitch as a WINS server
for multiple networks.
Comment 11 Jose Plans 2006-12-13 05:22:24 EST
Created attachment 143502 [details]
nmbd crash / stales.

Could you please try this patch ?
It did solve the issue for one of our customers having the very same traces you
got on this wins proxy problem.
Comment 14 Adam Thompson 2006-12-13 21:17:36 EST
*sigh*
We had to give up on the RHEL RPM packages a *long* time ago, and went with 
compiled source from the Samba project.
We just can't wait that long for a critical problem.
So, no, I actually can't test the patch.  Sorry...
Comment 16 RHEL Product and Program Management 2007-04-17 06:03:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 17 John Smith 2007-04-17 06:06:11 EDT
lol - and in the next 2 years - it is gonna be fixed!
Comment 18 Jose Plans 2007-04-17 12:55:24 EDT
https://bugzilla.samba.org/show_bug.cgi?id=2215
Comment 21 Simo Sorce 2007-04-27 11:50:01 EDT
*** Bug 229801 has been marked as a duplicate of this bug. ***
Comment 29 errata-xmlrpc 2007-11-15 11:14:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0698.html

Note You need to log in before you can comment on or make changes to this bug.