Bug 172764 - error message at hdparm -tT /dev/sda with SATA
Summary: error message at hdparm -tT /dev/sda with SATA
Status: CLOSED DUPLICATE of bug 138674
Alias: None
Product: Fedora
Classification: Fedora
Component: hdparm   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-09 10:51 UTC by Sebastian
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 10:57:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sebastian 2005-11-09 10:51:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
hdparm -tT /dev/sda gives the following errors

/dev/sda:
 Timing cached reads:   2440 MB in  2.00 seconds = 1219.92 MB/sec
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Inappropriate ioctl for device
 Timing buffered disk reads:  170 MB in  3.01 seconds =  56.44 MB/sec
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Inappropriate ioctl for device

This only happens on Systems with SATA and Fedora 4. On Fedora 3 with SATA everything works fine



Version-Release number of selected component (if applicable):
2.6.13-1.1532_FC4smp

How reproducible:
Always

Steps to Reproduce:
1.installing Fedora 4 on System with SATA
2.hdparm -tT /dev/sda

  

Actual Results:  i get the error messages posted above

Expected Results:  a normal hdparm test like on Fedora 3

Additional info:

on Systems with FEdora 4 and SATA we have high load while copying

Comment 1 Karsten Hopp 2005-11-09 10:57:42 UTC

*** This bug has been marked as a duplicate of 138674 ***

Comment 2 sangu 2006-03-30 11:54:33 UTC
This problem still happens in hdparm-6.3-2.2 and FC5.
$ sudo /sbin/hdparm -i /dev/sda
Reopen with version FC5.

/dev/sda:
 HDIO_GET_IDENTITY failed: Inappropriate ioctl for device

and hdparm 6.6 was released. 

Please See : http://sourceforge.net/project/showfiles.php?group_id=136732 


Note You need to log in before you can comment on or make changes to this bug.