Bug 1727853 - dnf download ignores destdir argument for some packages
Summary: dnf download ignores destdir argument for some packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf-plugins-core
Version: 8.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 8.0
Assignee: amatej
QA Contact: Luca Berton
URL:
Whiteboard:
Depends On: 1727137
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-08 11:21 UTC by Daniel Mach
Modified: 2020-04-28 16:49 UTC (History)
12 users (show)

Fixed In Version: dnf-4.2.16-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1727137
Environment:
Last Closed: 2020-04-28 16:48:04 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:03 UTC

Description Daniel Mach 2019-07-08 11:21:45 UTC
+++ This bug was initially created as a clone of Bug #1727137 +++

Description of problem:

dnf download ignores destdir argument when fetching remote packages through a local repository

Version-Release number of selected component (if applicable):
dnf-plugins-core-4.0.7-1.fc30

How reproducible:
Always

Steps to Reproduce:
1. Create a local repository using createrepo_c at /some/path

2. Merge a remote repository into it with mergerepo_c. Now you have a mix of some packages with just <location href="x86_64/foo-1.0.0-1.x86_64.rpm"> and some with <location xml:base="http://somewhere.else/" href="bar-2.0.0-2.x86_64.rpm">

3. dnf download --repofrompath="fred,file:///some/path" --repo fred --destdir /tmp foo bar


Actual results:

/some/path/x86_64/foo-1.0.0-1.x86_64.rpm is correctly copied to /tmp/foo-1.0.0-1.x86_64.rpm

BUT

http://somewhere.else/bar-2.0.0-2.x86_64.rpm is downloaded to /some/path/bar-2.0.0-2.x86_64.rpm

Whut?


Expected results:

Both foo-1.0.0-1.x86_64.rpm and bar-2.0.0-2.x86_64.rpm should be copied to /tmp

Additional info:

Comment 1 amatej 2019-08-21 08:54:27 UTC
I created a patch for DNF that should fix this: https://github.com/rpm-software-management/dnf/pull/1464

And here are tests for this: https://github.com/rpm-software-management/ci-dnf-stack/pull/589

Comment 7 errata-xmlrpc 2020-04-28 16:48:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.