Bug 1728019 - Ovirt creating preallocated disks when it should be creating thin-provisioned disks.
Summary: Ovirt creating preallocated disks when it should be creating thin-provisioned...
Keywords:
Status: CLOSED DUPLICATE of bug 1704782
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.3.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Tal Nisan
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-08 19:56 UTC by Darrell
Modified: 2019-07-08 20:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-08 20:15:33 UTC
oVirt Team: Storage
Embargoed:


Attachments (Terms of Use)

Description Darrell 2019-07-08 19:56:30 UTC
Description of problem: Ovirt creating preallocated disks when it should creating thin-provisioned disks.


Version-Release number of selected component (if applicable):
Ovirt 4.3.3.7
ovirt-imageio-common-1.5.1-0.el7.x86_64
ovirt-engine-4.3.3.7-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. edit VM in GUI
2. goto disk tab
3. add new disk, selecting Thin-provision from the menu.

Actual results:
[root@ovirt ovirt-engine]# grep vulc_Disk3 engine.log
2019-07-08 19:42:33,519Z INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CreateImageVDSCommand] (default task-967) [8908fd6a-7eab-4b7e-a350-120c15b8bbab] START, CreateImageVDSCommand( CreateImageVDSCommandParameters:{storagePoolId='00000002-0002-0002-0002-000000000331', ignoreFailoverLimit='false', storageDomainId='a10b0cc4-b6ec-4b26-bef0-316e0e7bdcac', imageGroupId='2e2655d1-ce8f-47e9-8832-2a5b147dd09a', imageSizeInBytes='21474836480', volumeFormat='RAW', newImageId='32d5e63d-374f-4d68-8341-11723edf3f51', imageType='Preallocated', newImageDescription='{"DiskAlias":"kovan1-vulc_Disk3","DiskDescription":""}', imageInitialSizeInBytes='0'}), log id: 81f14e7
2019-07-08 19:42:34,292Z INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-967) [8908fd6a-7eab-4b7e-a350-120c15b8bbab] EVENT_ID: USER_ADD_DISK_TO_VM(78), Add-Disk operation of kovan1-vulc_Disk3 was initiated on VM kovan1-vulc by telsin@ohgnetworks-authz.


Expected results:
imageType is Thin or Sparse, not Preallocated. Fallocate is not run.

Additional info:
possibly a revision from https://bugzilla.redhat.com/show_bug.cgi?id=1571285 ?
Also, fallocate against gluster 6.x seems very slow, maybe same on 5 from anecdotal evidence.

Comment 1 Darrell 2019-07-08 20:15:33 UTC
Nevermind, duplicate of 1704782, apparently my search terms weren't good enough to find it?

*** This bug has been marked as a duplicate of bug 1704782 ***


Note You need to log in before you can comment on or make changes to this bug.