Bug 1728055 - bodhi fails to build on Fedora 31 (rawhide)
Summary: bodhi fails to build on Fedora 31 (rawhide)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bodhi
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Randy Barlow
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1734858 1735390 (view as bug list)
Depends On: 1728071
Blocks: PYTHON38 F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-08 22:57 UTC by Miro Hrončok
Modified: 2019-08-24 17:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-24 17:59:06 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-07-08 22:57:49 UTC
bodhi fails to build with Python 3.8.0b1.

+ make -j2 -C docs html

Exception occurred:
  File "/usr/lib/python3.8/site-packages/sphinx/util/docfields.py", line 252, in __init__
    self.typemap = directive.get_field_type_map()
AttributeError: 'ServiceDirective' object has no attribute 'get_field_type_map'
The full traceback has been saved in /tmp/sphinx-err-_e3pcho4.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
A bug report can be filed in the tracker at <https://github.com/sphinx-doc/sphinx/issues>. Thanks!
make: *** [Makefile:51: html] Error 2
static/moment
copying bodhi/server/migrations/script.py.mako -> build/lib/bodhi/server/migrations
make: Entering directory '/builddir/build/BUILD/bodhi-4.0.2/docs'
Running Sphinx v2.1.2
making output directory... done
[autosummary] generating autosummary for: administration.rst, developer/index.rst, developer/models.rst, developer/releases.rst, developer/vagrant.rst, developer/virtualenv.rst, generated/buildroot_override.rst, generated/compose.rst, generated/composer.rst, generated/errata.rst, ..., user/man_pages/bodhi-sar.rst, user/man_pages/bodhi-shell.rst, user/man_pages/bodhi-skopeo-lite.rst, user/man_pages/bodhi-untag-branched.rst, user/man_pages/bodhi.rst, user/man_pages/index.rst, user/man_pages/initialize_bodhi_db.rst, user/release_notes.rst, user/testing.rst, user/update_states.rst
[autosummary] generating autosummary for: /builddir/build/BUILD/bodhi-4.0.2/docs/developer/docblocks/bodhi.server.models.rst
building [mo]: targets for 0 po files that are out of date
building [html]: targets for 49 source files that are out of date
updating environment: 50 added, 0 changed, 0 removed
reading sources... [  2%] administration
reading sources... [  4%] developer/docblocks/bodhi.server.models
reading sources... [  6%] developer/index
reading sources... [  8%] developer/models
reading sources... [ 10%] developer/releases
reading sources... [ 12%] developer/vagrant
reading sources... [ 14%] developer/virtualenv
reading sources... [ 16%] generated/buildroot_override
reading sources... [ 18%] generated/compose
reading sources... [ 20%] generated/composer
reading sources... [ 22%] generated/errata
reading sources... [ 24%] generated/update
reading sources... [ 26%] index
reading sources... [ 28%] python_bindings
reading sources... [ 30%] server_api/index
reading sources... [ 32%] server_api/messages/base
reading sources... [ 34%] server_api/messages/buildroot_override
reading sources... [ 36%] server_api/messages/compose
reading sources... [ 38%] server_api/messages/composer
reading sources... [ 40%] server_api/messages/errata
reading sources... [ 42%] server_api/messages/update
reading sources... [ 44%] server_api/rest/builds
make: Leaving directory '/builddir/build/BUILD/bodhi-4.0.2/docs'

I think that this is not related to Python 3.8 but Sphinx 2.1.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.8/fedora-rawhide-x86_64/00964711-bodhi/

For all our attempts to build bodhi with Python 3.8, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.8/package/bodhi/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.8:
https://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Let us know here if you have any questions.

Comment 1 Miro Hrončok 2019-07-08 23:40:12 UTC
This looks like it is caused by bz1728071.

Comment 2 Miro Hrončok 2019-07-08 23:46:56 UTC
Reproduced on rawhide.

Comment 3 Miro Hrončok 2019-07-31 19:57:25 UTC
*** Bug 1734858 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2019-08-02 10:21:07 UTC
*** Bug 1735390 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2019-08-02 10:23:18 UTC
We'd like to proceed with Python 3.8 rebuilds in Koji side tag the week after next. Without bodhi, we cannot have fedpkg and we cannot merge the side tag. I know that Randy is now away, so we'll probably just disable the docs in cornice and bodhi temporarily.

Comment 6 Ben Cotton 2019-08-13 17:03:15 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 7 Ben Cotton 2019-08-13 18:35:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 8 Miro Hrončok 2019-08-14 22:24:25 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 9 Miro Hrončok 2019-08-21 16:35:08 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 10 Miro Hrončok 2019-08-21 17:29:13 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 11 Kevin Fenzi 2019-08-24 17:59:06 UTC
This was fixed in 4.1.0-4.fc32.

https://koji.fedoraproject.org/koji/buildinfo?buildID=1358346


Note You need to log in before you can comment on or make changes to this bug.