Bug 172829 - Kernels later than 2.6.12-1.1456_FC4 hang during boot
Kernels later than 2.6.12-1.1456_FC4 hang during boot
Status: CLOSED DUPLICATE of bug 169738
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 22:17 EST by Jared Smith
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 04:09:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot messages on screen during hang (4.08 KB, text/plain)
2005-11-09 22:19 EST, Jared Smith
no flags Details
Output of "lspci" on a working kernel (32.70 KB, text/plain)
2005-11-09 22:23 EST, Jared Smith
no flags Details

  None (edit)
Description Jared Smith 2005-11-09 22:17:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I've got an HP nc6230 laptop, and whenever I boot any FC4 kernel newer than 2.6.12-1.1456_FC4, it hangs on boot.  With any FC4 kernel earlier than that (including .1456), the kernel boots just fine.  I've copied down the screens after booting 2.4.14-1.1636_FC4 the following four ways:

 o  with "quiet" and "rhgb" on the kernel command-line
 o  without "quiet" and "rhgb" on the kernel command-line
 o  with "pci=routeirq" on the kernel command-line
 o  and, finally, with "acpi=off" on the kernel command-line

In each of these cases, the kernel hangs on boot.  I'll attach a file to this bug that contains what was on the screen during each hang.  (Any typos are mine, as I copied these by hand.)

Version-Release number of selected component (if applicable):
2.4.14-1.1636_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot to kernel later than 2.6.12-1.1456_FC4 on an HP nc6320 laptop
2. Watch the kernel hang on boot
  

Actual Results:  The kernel hung

Expected Results:  I guess, I'd expect the kernel not to hang :-)

Additional info:

I've tried every version of the kernel between 2.6.12-1.1456_FC4 and 2.4.14-1.1636_FC4, and they all behave similarly.  I'm also going to attach a file containing the output of "lspci -vvv" and "lspci -nvvv" from the 2.6.12-1.1456_FC4 kernel.

I've also tried updating the laptop to the newest BIOS, in case it's a problem with the BIOS.  After updating the BIOS, it still behaves the same way.
Comment 1 Jared Smith 2005-11-09 22:19:34 EST
Created attachment 120872 [details]
Boot messages on screen during hang

This file lists what was on the screen during each of the tries.
Comment 2 Jared Smith 2005-11-09 22:23:28 EST
Created attachment 120873 [details]
Output of "lspci" on a working kernel

This file contains the output of "uname -a", "lspci -vvv", and "lspci -nvvv" on
a working kernel. I thought it might be useful.
Comment 3 Jared Smith 2005-11-09 22:29:56 EST
If it helps at all, I'd be willing to do more testing using this laptop, either
running different kernels, giving the output of other commands, disabling
on-board resources in the BIOS (if possible), etc.

Also, it appears that this bug *might* be related to 170205, but it seems kind
of a stretch.
Comment 4 Dave Jones 2005-11-10 16:59:31 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 5 Dave Jones 2005-11-11 04:09:46 EST

*** This bug has been marked as a duplicate of 169738 ***

Note You need to log in before you can comment on or make changes to this bug.