Bug 169738 - kernels-2.6.13-1.1526_FC4 hangs when booting
kernels-2.6.13-1.1526_FC4 hangs when booting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 169739 172184 172829 172916 173456 173482 (view as bug list)
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-10-02 12:43 EDT by José Matos
Modified: 2015-01-04 17:22 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 13:38:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description José Matos 2005-10-02 12:43:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
When booting after reading the initrd I get an oops: 
 
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1 
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1 
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1 

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
   

Additional info:

This is a laptop, an HP Compaq nx8220.  
  
I can provide more details if required. FWIW 2.6.12-1.1456_FC4 is running on  
this machine and this problem occurred also with kernel-2.6.13-1.1524_FC4
Comment 1 Dave Jones 2005-10-02 17:53:13 EDT
*** Bug 169739 has been marked as a duplicate of this bug. ***
Comment 2 Andy 2005-10-03 05:19:42 EDT
Same problem on a HP Compaq nc6220; maybe similar/identical hardware.
Comment 3 Jafaruddin Lie 2005-10-21 03:03:08 EDT
Latest kernel update is still the same (2.6.13-1.1532_FC4)
BTW I have NC6220 as well.
Comment 4 Petr Fischer 2005-10-22 09:22:35 EDT
Same problem (HP nx8220). Hang on boot with all this 2.6.13* kernels. Pity.
What is the problem? Some PCMCIA changes or what? Any patches?
Comment 5 José Matos 2005-10-22 09:33:08 EDT
I can confirm it again for 2.6.13-1.1532_FC4 as the previous reporters. 
Comment 6 Jun 2005-10-22 13:42:16 EDT
Confirming using 2.6.13-1.1532_FC4 on hp nx8220 hangs.  I have seen around the
net regarding initialization of cardbus is the possible problem.
Comment 7 Jun 2005-10-22 14:16:23 EDT
I have put acpi=noirq on my grub.conf for now as a workaround.

Bug is also tracked here:

http://bugzilla.kernel.org/show_bug.cgi?id=5221
Comment 8 Dave Jones 2005-11-05 02:17:52 EST
does the kernel at http://people.redhat.com/davej/kernels/Fedora/FC-4/ do any
better ?
Comment 9 José Matos 2005-11-05 09:19:45 EST
Nope. I see the same behaviour for every kernel on this list:  
kernel-2.6.13-1.1532_FC4 
kernel-2.6.14-1.1633_FC4 
kernel-2.6.14-1.1636_FC4 
 
the only way I found to boot the kernel is to pass acpi=noirq as one of 
the previous messages suggests. :-( 
Comment 10 Dave Jones 2005-11-10 14:06:06 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 11 José Matos 2005-11-10 14:43:17 EST
I am sorry, no change. :-( 
 
The update is not yet available from yum repositories but I got it from your 
homepage. 
 
$ uname -a 
Linux thunderbird 2.6.14-1.1637_FC4 #1 Wed Nov 9 18:19:37 EST 2005 i686 i686 
i386 GNU/Linux 
 
I should say also that, as all versions previously, if I pass the option 
acpi=noirq I get this warning after: 
 
PCI: Device 0000:00:1c.1 not available because of resource collision 
 
I am quoting this from memory, so any spell mistake is my fault, as this 
happens before the system logger runs. 
Comment 12 Dave Jones 2005-11-11 04:09:12 EST
*** Bug 172184 has been marked as a duplicate of this bug. ***
Comment 13 Dave Jones 2005-11-11 04:09:23 EST
*** Bug 172916 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2005-11-11 04:09:59 EST
*** Bug 172829 has been marked as a duplicate of this bug. ***
Comment 15 José Matos 2005-11-14 06:08:35 EST
I would like to report this problem is gone using kernel-2.6.14-1.1639_FC4   
from your homepage.   
   
I still get the same warnings as I had before, using acpi=noirq, but now no   
option needs to be passed for it to boot. The warnings are:   
  
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1 
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1 
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1 
PCI: Device 0000:00:1c.1 not available because of resource collision 
PCI: Device 0000:00:1c.1 not available because of resource collision 
 
This message shows after the line that says "uncompressing kernel..." 
 
I hope this helps, thank you. 
Comment 16 Dave Jones 2005-11-21 11:38:41 EST
*** Bug 173456 has been marked as a duplicate of this bug. ***
Comment 17 Dave Jones 2005-11-21 11:41:39 EST
*** Bug 173482 has been marked as a duplicate of this bug. ***
Comment 18 Sean Carlos 2005-11-30 08:29:03 EST
I am also seeing these messages; Acer Travelmate 4020 series. 2.6.14-1.1644_FC4
Comment 19 Dave Jones 2005-11-30 13:38:45 EST
This bug relates to a hang that was observed with HP laptops, which should be
fixed in 1644.  Can you open a new bug for your Acer please ?
Comment 20 Jun 2005-12-01 13:13:38 EST
I would like to report that 1644 works for my hp nx8220.  I do still see the
warning messages.
Comment 21 Keith Outwater 2005-12-01 14:41:53 EST
1644 also works for me on a hp nc8230.  I also see the warning messages.
Comment 22 Petr Fischer 2005-12-01 15:19:13 EST
1644 definitely works on nx8220 (with warning messages). Thanks!

Note You need to log in before you can comment on or make changes to this bug.