Bug 1728447 - [OSP15] set default ulimit to nova_libvirt
Summary: [OSP15] set default ulimit to nova_libvirt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Martin Schuppert
QA Contact: Archit Modi
URL:
Whiteboard:
Depends On:
Blocks: 1729552 1729553
TreeView+ depends on / blocked
 
Reported: 2019-07-10 01:26 UTC by Meiyan Zheng
Modified: 2019-09-26 10:53 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190711090428.245f17c.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1729552 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:23:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1762455 0 None None None 2019-07-12 15:25:27 UTC
OpenStack gerrit 668690 0 None None None 2019-07-12 15:25:27 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:11 UTC

Description Meiyan Zheng 2019-07-10 01:26:18 UTC
Description of problem:
There is an issue in DPDK node as below because of high ulimit in nova_libvirt container and libvirt behavior when closing FD. 
https://bugzilla.redhat.com/show_bug.cgi?id=1721434

Please also consider to set default ulimit for nova_libvirt in heat template file. I can see a patch is provided in upstream, is it possible to include this to downstream version?
https://review.opendev.org/#/c/668416/

Current workaround is in BZ#1721434 comment#59. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 10 errata-xmlrpc 2019-09-21 11:23:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.