Bug 1729552 - [OSP14] set default ulimit to nova_libvirt
Summary: [OSP14] set default ulimit to nova_libvirt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z4
: 14.0 (Rocky)
Assignee: Martin Schuppert
QA Contact: James Parker
URL:
Whiteboard:
Depends On: 1728447
Blocks: 1729553
TreeView+ depends on / blocked
 
Reported: 2019-07-12 15:27 UTC by Martin Schuppert
Modified: 2019-11-06 16:49 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-9.3.1-0.20190513171753.el7ost
Doc Type: No Doc Update
Doc Text:
Clone Of: 1728447
: 1729553 (view as bug list)
Environment:
Last Closed: 2019-11-06 16:48:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1762455 None None None 2019-07-12 15:27:38 UTC
OpenStack gerrit 668688 None None None 2019-07-12 15:27:38 UTC
Red Hat Product Errata RHBA-2019:3745 None None None 2019-11-06 16:49:19 UTC

Description Martin Schuppert 2019-07-12 15:27:39 UTC
+++ This bug was initially created as a clone of Bug #1728447 +++

Description of problem:
There is an issue in DPDK node as below because of high ulimit in nova_libvirt container and libvirt behavior when closing FD. 
https://bugzilla.redhat.com/show_bug.cgi?id=1721434

Please also consider to set default ulimit for nova_libvirt in heat template file. I can see a patch is provided in upstream, is it possible to include this to downstream version?
https://review.opendev.org/#/c/668416/

Current workaround is in BZ#1721434 comment#59. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Lon Hohberger 2019-09-04 10:43:34 UTC
According to our records, this should be resolved by openstack-tripleo-heat-templates-9.3.1-0.20190513171752.el7ost.  This build is available now.

Comment 5 James Parker 2019-09-13 20:11:16 UTC
Version Checked:
(undercloud) [stack@undercloud-0 ~]$ rpm -qa | grep heat-templates
openstack-tripleo-heat-templates-9.3.1-0.20190513171752.el7ost.noarch

nova_compute appears to have the updated default of 131072 units, but nova_libvirt does not:

[heat-admin@compute-0 ~]$ sudo docker exec -it nova_compute prlimit | grep NOFILE
NOFILE     max number of open files              131072    131072 
[heat-admin@compute-0 ~]$ sudo docker exec -it nova_libvirt prlimit | grep NOFILE
NOFILE     max number of open files             1048576   1048576

Comment 10 errata-xmlrpc 2019-11-06 16:48:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3745


Note You need to log in before you can comment on or make changes to this bug.