Bug 172864 - Only one profile can be active at one time
Only one profile can be active at one time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 164856 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 13:03 EST by Stefan Becker
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-18 16:56:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2005-11-10 13:03:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051109 Fedora/1.5-0.5.0.rc1.NOEL.1 Firefox/1.5

Description of problem:
Firefox currently seems only to be able to handle one profile at a time, ie. if you start it with one profile you can't start another instance using another profile.

Version-Release number of selected component (if applicable):
firefox-1.5-0.5.0.rc1

How reproducible:
Always

Steps to Reproduce:
1. Setup firefox with two profiles: profile1, profile2
2. firefox -P profile1
3. firefox -P
4. firefox -P profile2
  

Actual Results:  3. Opens new window in the "profile1" instance
4. Opens new window in the "profile1" instance

Expected Results:  3. Start new instance showing profile manager
4. Start new instance using profile2

Additional info:

I took the Rawhide SRPM and was able to compile it for RHEL4 after minor modifications (disable pango, disable system cairo, nspr -> mozilla-nspr). After noticing the profile problem I tried to re-compile with 

 "ac_add_options --disable-single-profile"

added to firefox-mozprofile but then the build fails with:

gmake[1]: Entering directory `/workarea/rpm/BUILD/mozilla/profile/src'
nsProfile.cpp
c++ -o nsProfile.o ...
In file included from nsProfile.cpp:39:
nsProfile.h:46:31: nsICmdLineService.h: No such file or directory
nsProfile.cpp:80:34: nsIChromeRegistrySea.h: No such file or directory
...
gmake[1]: *** [nsProfile.o] Error 1
nsProfileAccess.cpp
c++ -o nsProfileAccess.o ...
In file included from nsProfileAccess.cpp:41:
nsProfile.h:46:31: nsICmdLineService.h: No such file or directory
gmake[1]: *** [nsProfileAccess.o] Error 1

It seems that the current Firefox 1.5RC1 only compiles for single profile usage...
Comment 1 Stefan Becker 2005-11-18 16:28:44 EST
Problem still exists in 1.5 RC3. I've now also reported it to upstream

<https://bugzilla.mozilla.org/show_bug.cgi?id=317040>
Comment 2 Stefan Becker 2005-11-18 16:56:53 EST
This is intentional according to

 <https://bugzilla.mozilla.org/show_bug.cgi?id=271191>

"To enable multiple Firefox instances, you need to set MOZ_NO_REMOTE=1 as an
environment variable in Windows, otherwise, invoking Firefox will always add to
the current instance.  This is by design and not likely to change at any time in
the forseeable future."

I verified that this environment variable works. This variable seems to be new
for Firefox 1.5 as it worked without it in Firefox 1.0.x.
Comment 3 Stefan Becker 2005-11-18 17:45:26 EST
See also

   <https://bugzilla.mozilla.org/show_bug.cgi?id=308076>
Comment 4 Christopher Aillon 2007-04-17 10:59:46 EDT
*** Bug 164856 has been marked as a duplicate of this bug. ***
Comment 5 Till Maas 2007-05-08 16:20:01 EDT
*** Bug 164856 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.