Bug 172866 - Allows entry of empty environment variables
Allows entry of empty environment variables
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-httpd (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 172877 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 13:29 EST by Ian Chapman
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 12:23:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Chapman 2005-11-10 13:29:19 EST
From Bugzilla Helper:
User-Agent: Opera/8.5 (X11; Linux x86_64; U; en)

Description of problem:
The tool allows you to enter empty environment variables for CGI scripts, this 
breaks apache's syntax, it fails to restart and an error is produced, for 
example:

SetEnv takes 1-2 arguments, an environment variable name and optional value to 
pass to CGI.


Version-Release number of selected component (if applicable):
 system-config-httpd-1.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Edit or add a virtual host.
2. Click environment tab
3. Click add, but press OK without entering anything
4. Apply the changes
5. Restart apache
  

Actual Results:  Apache fails to restart and an error is produced.

Expected Results:  The tool should not produce invalid syntax in the apache configuration file. A 
warning should be given to the user.

Additional info:
Comment 2 Phil Knirsch 2006-10-25 11:27:25 EDT
*** Bug 172877 has been marked as a duplicate of this bug. ***
Comment 3 Phil Knirsch 2008-08-18 12:23:21 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.