Bug 1728711 - Mgr metdata and status required to be added to prometheus exporter module
Summary: Mgr metdata and status required to be added to prometheus exporter module
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Mgr Plugins
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 4.0
Assignee: Boris Ranto
QA Contact: Madhavi Kasturi
URL:
Whiteboard:
Depends On:
Blocks: 1728723
TreeView+ depends on / blocked
 
Reported: 2019-07-10 14:04 UTC by Anmol Sachan
Modified: 2020-01-31 12:46 UTC (History)
6 users (show)

Fixed In Version: ceph-14.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:46:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 40713 0 None None None 2019-07-10 14:04:05 UTC
Github ceph ceph pull 29168 0 'None' closed nautilus: mgr: Add mgr metdata to prometheus exporter module 2020-01-23 20:27:37 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:56 UTC

Description Anmol Sachan 2019-07-10 14:04:06 UTC
Description of problem: Following fields need to be added to the prometheus exporter module :

-MGR_METADATA
-MGR_STATUS
-MGR_MODULE_STATUS
-MGR_MODULE_CAN_RUN


Version-Release number of selected component (if applicable): Needs to be Backported to V14.2.1 NAUTILUS.


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anmol Sachan 2019-09-24 13:22:10 UTC
The backport PR was merged and this bug can be closed now.

Comment 8 errata-xmlrpc 2020-01-31 12:46:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.