Bug 172915 - acpi battery info lost after running for a while
acpi battery info lost after running for a while
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 172995 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 03:34 EST by Thomas M Steenholdt
Modified: 2015-01-04 17:23 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 20:15:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
snip of my messages log showing the problem (40.89 KB, text/plain)
2005-11-12 20:03 EST, Thomas M Steenholdt
no flags Details

  None (edit)
Description Thomas M Steenholdt 2005-11-11 03:34:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051104 Fedora/1.5-0.5.0.rc1.tmus Firefox/1.5

Description of problem:
The /proc/acpi/battery/BAT0/info node provides me with info regarding my laptop battery. However after suspend/resume, even though it may work initially, it will eventually barf and return something like:

# cat /proc/acpi/battery/BAT0/info
present:                 yes
ERROR: Unable to read battery information

taking a look in /var/log/messages shows these suspect (at least to me) messages:

08:36:23 host kernel: ACPI-0292: *** Error: Looking up [SERN] in namespace, AE_ALREADY_EXISTS
08:36:23 host kernel: ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.GBIF] (Node f7ec2c00), AE_ALREADY_EXISTS
08:36:23 host kernel: ACPI-0213: *** Error: Method reached maximum reentrancy limit (255)
08:36:23 host kernel: ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BAT0._BIF] (Node f7ec2ac0), AE_AML_METHOD_LIMIT
08:36:23 host kernel: ACPI-0213: *** Error: Method reached maximum reentrancy limit (255)
08:36:23 host kernel: ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BAT0._BIF] (Node f7ec2ac0), AE_AML_METHOD_LIMIT

... some time passes ...

09:18:08 host kernel: ACPI-0213: *** Error: Method reached maximum reentrancy limit (255)
09:18:08 host kernel: ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BAT0._BIF] (Node f7ec2ac0), AE_AML_METHOD_LIMIT

At this point I can't be 100% sure that it's related to the suspend/resume, but that how it feels - I've yet to see the problem after a normal reboot.

Could it possibly be related to Bug #154046 ?

My laptop is a ThinkPad T30 (2366JBG)

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4

How reproducible:
Sometimes

Steps to Reproduce:
1. Boot, check battery status
2. Suspend/Resume
3. Watch battery status periodically and wait for it to fail
  

Actual Results:  Fails at some point

Expected Results:  Should never fail

Additional info:
Comment 1 Thomas M Steenholdt 2005-11-11 03:35:47 EST
(reproducible sometimes, cuz it takes some time, so perhaps there's and odd
chance it'll actually keep working)
Comment 2 Thomas M Steenholdt 2005-11-12 19:56:13 EST
Update:

This is NOT related to suspend...

Almost exactly 30 minutes from clean boot, i get this :
ACPI-0292: *** Error: Looking up [SERN] in namespace, AE_ALREADY_EXISTS
ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.GBIF] (Node
f7ec2c00), AE_ALREADY_EXISTS

then after about another half hour, these :
ACPI-0213: *** Error: Method reached maximum reentrancy limit (255)
ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BAT0._BIF]
(Node f7ec2ac0), AE_AML_METHOD_LIMIT

and these keep coming in what seems like intervals af around 30 minutes.

I'll attact the full log
Comment 3 Thomas M Steenholdt 2005-11-12 20:03:40 EST
Created attachment 120996 [details]
snip of my messages log showing the problem

there are a few other acpi related errors that may or may not prove interesting
to this case
Comment 4 Tayfun Can 2005-11-13 09:25:48 EST
I have a IBM Thinkpad R40. I see the same ACPI messages almost immediately.
I am running kernel 2.6.14-1.1637_FC4

I tried to set ec_burst=1 which allowed me to see the proper battery info
(/proc/acpi/batter/BAT0/info) for a few min after the boot, but it went back 
to "ERROR: Unable to read battery information".
Comment 5 David Baron 2005-11-16 01:25:43 EST
I see the same problem on a ThinkPad T42.

It's worth noting that this worked fine on Fedora Core 3, and I used the laptop
for weeks at a time, frequently suspending and resuming, without problems.

Bug 172995 appears to be a duplicate of this one.
Comment 6 David Perkinson 2005-11-18 01:53:16 EST
Same problem on a ThinkPad X40 (with kernel 2.6.14-1.1637_FC4.
Comment 7 Seva 2005-11-18 02:47:36 EST
I have the same or very similiar problem on my IBM ThinkPad X40 on
2.6.14-1.1637_FC4, as far as I can tell /proc/acpi/battery/BAT0/info is broken
as soon as I boot up:

2.6.14-1.1637_FC4# cat /proc/acpi/battery/BAT0/info
present:                 yes
ERROR: Unable to read battery information

Last kernel I've used was 2.6.13-1.1526_FC4 and it worked as expected, I have
not  had a chance to try kernel releases inbetween the two mentioned.
Comment 8 Dave Jones 2005-11-21 11:14:27 EST
*** Bug 172995 has been marked as a duplicate of this bug. ***
Comment 9 Kevin R. Page 2005-11-25 06:41:10 EST
If I pass kernel option "acpi_serialize" I don't see this problem any more (or
at least I haven't seen it yet, with a several hour uptime).

Alas, I'm not sure _why_ this fixes it - acpi_serialize was mentioned in a
couple of similar (but probably not the same? further investigation needed)
entries in bugzilla.kernel.org. Google turned it up too. A last ditch effort
before I turned in for the night, which happened to work...

Thinkpad X31 (2672-C8G), 2.6.14-1.1637_FC4
Comment 10 Tayfun Can 2005-11-25 13:29:55 EST
Kernel option "acpi_serialize" seems to fix the issue on my system as well. I
don't see any ACPI error messages in /var/log/messages and battery status is
reported properly.

Thinkpad R40, 2.6.14-1.1637_FC4
Comment 11 Jacek Chrząszcz 2005-11-25 14:46:51 EST
I have recompiled the 2.6.14-1.1637_FC4 kernel with the sata patch
http://lkml.org/lkml/2005/9/23/97 , and with config setting pentium M and
disabling some exotic (to me ;) devices and I do not have any problems since on
my X41.

I quite often suspend and resume the machine (this works now thanks to the sata
patch), the system has not been rebooted for a few days now.

I am not sure if this information would be helpful to anybody, but I wanted to
share just in case ;)

Jacek
Comment 12 Daniel Roesen 2005-12-14 19:07:47 EST
Seeing similar problems on my new IBM Thinkpad R52. It works, but sometimes
fails. When it fails, I see something like:

[dr@thinko ~]$ cat /proc/acpi/battery/BAT0/info
present:                 yes
ERROR: Unable to read battery information

[dr@thinko ~]$ cat /proc/acpi/battery/BAT0/state
present:                 yes
capacity state:          ok
charging state:          charged
present rate:            0 mW
remaining capacity:      51840 mWh
present voltage:         12432 mV

I didn't have that problem for some time after booting while the quite drained
battery was charging, but later on when it was indeed charged full I saw the N/A
in GNOME's battery applet. No idea wether timing is of any relevance, just wanted
to mention.

Much more interesting is:

[root@thinko ~]# cat /proc/acpi/power_resource/PUBS/state
state:                   on
system level:            S3
order:                   0
reference count:         0

Does this box think that it's suspended (S3)? [something that doesn't work at
all out-of-the-box in FC4, neither to-disk nor to-ram, didn't get around to
try making it work yet]

Didn't play with any suspend/ACPI settings at all.
Comment 13 Daniel Roesen 2005-12-14 19:09:34 EST
forgot to mention: 2.6.14-1.1644_FC4
Comment 14 Dave Jones 2005-12-14 21:02:19 EST
please test with the latest update (1653)
Comment 15 Kevin R. Page 2005-12-15 19:47:35 EST
Thinkpad X31 (2672-C8G), 2.6.14-1.1653_FC4, acpi_serialize no longer set - seems
to have fixed things for me (10 hour uptime so far).

Note You need to log in before you can comment on or make changes to this bug.