Bug 172995 - Battery info stops working after some time on IBM X41
Summary: Battery info stops working after some time on IBM X41
Status: CLOSED DUPLICATE of bug 172915
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FCMETA_ACPI
TreeView+ depends on / blocked
 
Reported: 2005-11-11 21:50 UTC by Jacek Chrząszcz
Modified: 2015-01-04 22:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 16:14:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The contents of /var/log/messages since last restart (40.72 KB, text/plain)
2005-11-11 21:57 UTC, Jacek Chrząszcz
no flags Details

Description Jacek Chrząszcz 2005-11-11 21:50:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.12) Gecko/20050927 Fedora/1.0.7-2.1.fc4.nr Firefox/1.0.7

Description of problem:
After some time of working, the battery indication gadget stops showing the status correctly.
Battery info in /proc/acpi/battery/BAT0/info stops working either.


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4

How reproducible:
Always

Steps to Reproduce:
1. Work for some time with the battery indication gadget (maybe 1 hour)
2. The battery indication gadget starts showing a !
3. Now do
cat /proc/acpi/battery/BAT0/info

  

Actual Results:  present:                   yes
ERROR: Unable to read battery information

Expected Results:  correct battery status

Additional info:

the following error message is in /var/log/messages:

Nov 11 22:44:37 minio kernel:     ACPI-0213: *** Error: Method reached maximum reentrancy limit (255)
Nov 11 22:44:37 minio kernel:     ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BAT0._BIF] (Node df586580), AE_AML_METHOD_LIMIT

The new message is appended every time /proc/acpi/battery/BAT0/info is accessed

Comment 1 Jacek Chrząszcz 2005-11-11 21:57:25 UTC
Created attachment 120967 [details]
The contents of /var/log/messages since last restart

The first ACPI error is this one:

Nov 11 20:37:58 minio kernel:	  ACPI-0292: *** Error: Looking up [SERN] in
namespace, AE_ALREADY_EXISTS
Nov 11 20:37:58 minio kernel:	  ACPI-0508: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__.GBIF] (Node df5866c0), AE_ALREADY_EXISTS

There are no 3rd party modules in the kernel (only the ipw2200 firmware).

Comment 2 Gerald Britton 2005-11-12 19:04:09 UTC
I'm having the same issue on my T40p 2373-G3U.  Same messages printed by this
kernel as the previous reporters.  I've had similar issues with 2.6.13 as well,
but hadn't had time to report it into bugzilla.  The messages were more of the
"Looking up [SERN] .. AE_ALREADY_EXISTS" and similar messages.

kernel-2.6.12-1.1456_FC4  Appears to work fine.
kernel-2.6.13-1.1526_FC4  Fails intermittantly.
kernel-2.6.13-1.1532_FC4  Fails intermittantly.
kernel-2.6.14-1.1637_FC4  Fails quickly, stays failed.

Comment 3 Tayfun Can 2005-11-13 15:03:26 UTC
Same issue on IBM R40. 

Comment 4 David Baron 2005-11-16 06:25:12 UTC
Is this a duplicate of bug 172915?

Comment 5 Dave Jones 2005-11-21 16:14:00 UTC

*** This bug has been marked as a duplicate of 172915 ***


Note You need to log in before you can comment on or make changes to this bug.