Bug 172916 - boot hang - cannot allocate resource region
boot hang - cannot allocate resource region
Status: CLOSED DUPLICATE of bug 169738
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 03:42 EST by Petr Fischer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 04:09:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Fischer 2005-11-11 03:42:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Boot hang with 2.6.13* and 2.6.14 kernels.

Error message before hang:
-----------------------
PCI: cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: cannot allocate resource region 9 of bridge 0000:00:1c.1
-----------------------

lspci -v fragment:
-----------------------
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03) (prog-if 00 [Normal decode])        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=10, subordinate=10, sec-latency=0
        Memory behind bridge: c8000000-c83fffff
        Capabilities: [40] Express Root Port (Slot+) IRQ 0
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2
        Capabilities: [100] Virtual Channel
        Capabilities: [180] Unknown (5)

00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03) (prog-if 00 [Normal decode])        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=20, subordinate=20, sec-latency=0
        I/O behind bridge: 00000000-00000fff
        Memory behind bridge: 00000000-000fffff
        Prefetchable memory behind bridge: 0000000000000000-0000000000000000
        Capabilities: [40] Express Root Port (Slot+) IRQ 0
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2
        Capabilities: [100] Virtual Channel
        Capabilities: [180] Unknown (5)
-----------------------

I am sticked with 2.6.11 kernel.
This is long term problem.

Hardware: HP notebook nx8220 (some users report this problem on nx6120).

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4

How reproducible:
Always

Steps to Reproduce:
Simply boot on new HP notebooks (nx8220).
  

Additional info:
Comment 1 Mogens Kjaer 2005-11-11 03:59:57 EST
I have a HP nw8240 with the same problem.

It boots fine with acpi=off, however, it
still gives the error message above, so I'm not sure that
this error message is relevant.

This is what it writes:
...
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1
PCI: Bridge: 0000:00:01.0
  IO window: 2000-2fff
  MEM window: c8800000-c8bfffff
  PREFETCH window: c0000000-c7ffffff
PCI: Bridge: 0000:00:1c.0
  IO window: disabled.
  MEM window: c8000000-c83fffff
  PREFETCH window: disabled.
...

Can you boot a newer kernel with acpi=off?
Comment 2 Dave Jones 2005-11-11 04:09:14 EST

*** This bug has been marked as a duplicate of 169738 ***
Comment 3 Petr Fischer 2005-11-11 06:41:05 EST
"acpi=off" is no solution.

With acpi=off, this messages occurs:
----------------------
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1
PCI: Device 0000:00:1c.1 not available because of resource collisions
PCI: Device 0000:00:1c.1 not available because of resource collisions
----------------------

(See new 2 lines on end)

acpi=off is not solution for me at all - I need batery status etc...
Comment 4 Mogens Kjaer 2005-11-11 07:37:59 EST
Does acpi=noirq work, as suggested in bug 169738?
Comment 5 Petr Fischer 2005-11-11 08:21:58 EST
Yes - acpi=noirq works. PCI error messages (from Comment #3) still occurs, but
booting continues. Thanks.
Comment 6 Frank Trila 2005-11-24 06:03:02 EST
for me with kernel 2.6.14-1.1637_FC4 the system (HP nc6220) hangs on boot even
when I apply apci=noirq
Comment 7 Mogens Kjaer 2005-11-24 06:05:53 EST
(In reply to comment #6)
> for me with kernel 2.6.14-1.1637_FC4 the system (HP nc6220) hangs on boot even
> when I apply apci=noirq

Is this a typo?

It should be acpi=noirq
Comment 8 Frank Trila 2005-11-24 06:10:14 EST
YES it was a typo !! With acpi=noirq it works !!!

Note You need to log in before you can comment on or make changes to this bug.