Bug 1729262 - [Regression] Appliance console showing in correct Region number
Summary: [Regression] Appliance console showing in correct Region number
Keywords:
Status: CLOSED DUPLICATE of bug 1690158
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.10.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.8
Assignee: Keenan Brock
QA Contact: Md Nadeem
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 17:25 UTC by Jared Deubel
Modified: 2019-07-23 14:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-22 15:25:16 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Jared Deubel 2019-07-11 17:25:49 UTC
Description of problem:
There is a regression in Appliance console showing in which we show the incorrect Region number. This is due to the removal of the REGIONS file in the vmdb directory. When creating a new REGION file the appliance_console will reflect the number that was created. 

Version-Release number of selected component (if applicable):
5.10.6

Comment 2 Marianne Feifer 2019-07-16 18:56:12 UTC
In Dennis' absence, GreggT said that should have Keenan look at this one.

Comment 3 Keenan Brock 2019-07-18 16:51:39 UTC
Looks like this was fixed before 5.10.6. So there shouldn't be a problem in 10.6

For reference, #1690158
https://github.com/ManageIQ/manageiq-appliance_console/issues/79
https://github.com/ManageIQ/manageiq/pull/18444



I created a cfme appliance. I created a database with region 33.
I ensured there was no file: /var/www/miq/vmdb/REGION

In appliance_console I see:

Database/Region:         vmdb_production / 33
External Auth:           not configured
CFME Version:            5.10.6.1


Hey Jared,
Is the incorrect region number showing a 0 or a 1?

--K

Comment 4 Jared Deubel 2019-07-22 15:25:16 UTC
Tested this on the latest of 5.10 and it seems to be working and fixed in bz: https://bugzilla.redhat.com/show_bug.cgi?id=1690158


Closing out ticket.

*** This bug has been marked as a duplicate of bug 1690158 ***


Note You need to log in before you can comment on or make changes to this bug.