Bug 172946 - Unable to suspend an IBM T42p
Unable to suspend an IBM T42p
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: FCMETA_USB
  Show dependency treegraph
 
Reported: 2005-11-11 10:26 EST by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-21 04:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2005-11-11 10:26:33 EST
Description of problem:
Suspend on my T42p laptop fails because hci-usb complains.


Version-Release number of selected component (if applicable):
kernel 2.6.14-1.1660

How reproducible:
every time


Steps to Reproduce:
1. start system
2. enter "echo 'mem' > /sys/power/state'
3.
  
Actual results:
system fails to suspend and /var/log/messages contains:
Nov 11 07:49:24 basso kernel: Stopping tasks:
=========================================================================================================|
Nov 11 07:49:24 basso kernel: hci_usb 4-1:1.1: no suspend?
Nov 11 07:49:24 basso kernel: hci_usb 4-1:1.0: no suspend?
Nov 11 07:49:24 basso kernel: Could not suspend device 4-1: error -16
Nov 11 07:49:24 basso kernel: Some devices failed to suspend
Nov 11 07:49:24 basso kernel: Restarting tasks... done




Expected results:
system should suspend


Additional info:

I don't know if this is helpful, but I have run the same machine with the recent
FC4 kernel update, 2.6.14-1.1637_FC4, suspends fine
Comment 1 Dave Jones 2006-03-04 17:49:34 EST
Try latest rawhide, and use pm-suspend rather than writing to the sysfs files
directly.
Comment 2 Dave Jones 2006-10-16 20:30:59 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 3 Brian G. Anderson 2006-10-18 12:46:52 EDT
Suspend has worked for me using the latest fc5 kernels for a while now.
Comment 4 Brian G. Anderson 2006-10-18 12:47:13 EDT
Suspend has worked for me using the latest fc5 kernels for a while now.

Note You need to log in before you can comment on or make changes to this bug.