Bug 1729922 - [Docs] Networking Guide: ToC hyperlinks broken
Summary: [Docs] Networking Guide: ToC hyperlinks broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Greg Rakauskas
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks: 1715822
TreeView+ depends on / blocked
 
Reported: 2019-07-15 10:31 UTC by Thom Carlin
Modified: 2019-07-23 17:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 17:53:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Thom Carlin 2019-07-15 10:31:38 UTC
Description of problem:

For https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/networking_guide/index many links are broken

Version-Release number of selected component (if applicable):

10-z

How reproducible:

100% for specific links

Steps to Reproduce:
1. Navigate to https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/networking_guide/index
2. Select link (at random) in panel on left
3. Watch where the link goes to

Actual results:

Most links resolve to top of document

Expected results:

All links resolve to corresponding section of the document (i.e. Chapter 11 actually goes to Chapter 11, not Section 2.3.  For this specific case, the resolution URL is https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/networking_guide/index#security_groups which suggests a ToC generation issue)

Additional info:

Comment 3 Greg Rakauskas 2019-07-23 17:53:23 UTC
Hi Thom,

Thanks so much for noticing this defect and telling the RHOSP Doc team!

It turns out that this error was caused by an AsciiDoc tagging error.

Thanks to Dan McPherson who discovered the fix!

We have fixed it in OSP 10, 9, and 8.

The fixes are live and customers can see the fixes here:

 - OSP 10
   https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/networking_guide/index

 - OSP  9
   https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/9/html-single/networking_guide/index

 - OSP  8
   https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/9/html-single/networking_guide/index   


Thanks again!
--Greg


Note You need to log in before you can comment on or make changes to this bug.