Bug 1730073 - Podman related validations fail on permission problem
Summary: Podman related validations fail on permission problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: Gaël Chamoulaud
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks: 1661790
TreeView+ depends on / blocked
 
Reported: 2019-07-15 18:44 UTC by Amit Ugol
Modified: 2019-09-27 10:43 UTC (History)
13 users (show)

Fixed In Version: python-tripleoclient-11.5.1-0.20190710165436.3f572d6.el8ost
Doc Type: Bug Fix
Doc Text:
In some earlier Red Hat OpenStack Platform versions, the following validations were not working: - neutron-sanity-check - rabbitmq-limits - undercloud-process-count - undercloud-tokenflush - undercloud-heat-purge-deleted In RHOSP 15, this problem has been corrected. A new director CLI now allows you to run the earlier listed validations through Red Hat Ansible Automation directly from the Undercloud machine.
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 655165 0 None MERGED Allow running validations by name using Ansible by default. 2020-10-24 10:01:12 UTC
OpenStack gerrit 668855 0 None MERGED Allow running validations by group using Ansible by default 2020-10-24 10:01:13 UTC
OpenStack gerrit 669814 0 None MERGED Allow running validations by name using Ansible by default. 2020-10-24 10:01:13 UTC
OpenStack gerrit 669846 0 None MERGED Allow running validations by group using Ansible by default 2020-10-24 10:01:13 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:11 UTC

Description Amit Ugol 2019-07-15 18:44:41 UTC
Description of problem:
Running a validation related to running a podman command will fail because there are no permissions to touch /var/run/libpod/alive.lck

[root@undercloud-0 ~]# ls -l /var/run/libpod/
total 0
-rw-r--r--. 1 root root    0 Jul 15 11:56 alive
-rw-------. 1 root root    0 Jul 15 11:56 alive.lck
drwxr-x---. 2 root root   40 Jul 15 12:14 exits
drwxr-xr-x. 2 root root 2600 Jul 15 12:14 lock
drwxr-x---. 2 root root 1040 Jul 15 12:14 socket

[root@undercloud-0 ~]# getfacl /var/run/libpod/alive.lck
getfacl: Removing leading '/' from absolute path names
# file: var/run/libpod/alive.lck
# owner: root
# group: root
user::rw-
group::---
other::---

Version-Release number of selected component (if applicable):
openstack-tripleo-validations-10.4.1-0.20190701170405.10b4d77.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
run a podman related validation such as "undercloud-heat-purge-deleted"

Actual results:
[FAILED] - undercloud-heat-purge-deleted
    Task 'undercloud-heat-purge-deleted : Get heat crontab' failed:
    Host: undercloud
    Message: Command `set -o pipefail
    podman exec heat_api_cron crontab -l -u heat |grep -v '^#'
    ` exited with code: 1: non-zero return code
    stderr:
        error creating libpod runtime: error acquiring runtime init lock: error opening "/var/run/libpod/alive.lck": permission denied
    Failure! The validation failed for all hosts:
    * undercloud

Expected results:
Test should be able to run fully.

Comment 12 errata-xmlrpc 2019-09-21 11:23:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.