Bug 173012 - httpd configuration directory for virtual hosts?
httpd configuration directory for virtual hosts?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
: 232393 246569 (view as bug list)
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2005-11-12 06:51 EST by Robert Scheck
Modified: 2013-01-09 22:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 08:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-11-12 06:51:29 EST
Description of problem:
I would like to see a httpd configuration directory, which is used only for 
virtual hosts, like other distributions have it (as far, as I found while 
googling around):

SuSE/Novell: /etc/apache2/vhosts.d/
Debian: /etc/apache2/vhosts/
Gentoo: /etc/apache2/vhosts.d/
Mandriva: /etc/httpd/conf/vhosts/

Personally, I would prefer /etc/httpd/vhosts.d/ like at SuSE/Novell and Gentoo. 
This would require a include in delivered httpd.conf and one line more in 
SELinux src/policy/file_contexts/program/apache.fc.

At least I didn't find an official suggestion for naming this directory, maybe 
you know something better, because you are an Apache guy, aren't you? ;-)

Version-Release number of selected component (if applicable):
httpd-2.0.54-16
Comment 1 Robert Scheck 2005-12-02 19:49:23 EST
Ping...any chance to get this into the httpd 2.2.0 rpm package - and maybe into 
FC5?!
Comment 2 Jesse Keating 2006-08-17 18:51:09 EDT
Is there any particular reason why the /etc/httpd/conf.d/ directory isn't
suitable?  Why add more directories?
Comment 3 Robert Scheck 2006-08-18 11:23:38 EDT
I'm looking for a directory only used for virtual hosts where any 3rd party 
software could be restricted to (e.g. Confixx-like software). I think keeping 
virtual hosts separate from mod_perl, mod_php or mod_python configuration is 
reason enough for this.

My thinking is especially then useful, if you've got one file per virtual host 
and don't want to search for any configuration file which is not a virtual host 
configuration file...

Asked the other way round: Where is the problem to add the directory? Fedora 
Core is currently the only big distribution not providing such a IMHO useful 
possibility.
Comment 4 Robert Scheck 2006-09-23 13:26:13 EDT
Ping...what's status for FC6?
Comment 5 Matthias Saou 2006-09-28 10:24:42 EDT
First of all, I'd not consider this a Blocker bug myself, but that's just my
opinion.

Second of all, I've been creating /etc/httpd/conf.d/vhost-*.conf files for ages
to achieve the same thing.

But maybe just addding this to the httpd package :
/etc/httpd/conf.d/vhosts.conf
/etc/httpd/conf.d/vhosts.d/

With /etc/httpd/conf.d/vhosts.conf being :

NameVirtualHost *:80
Include conf.d/vhosts.d/*.conf

or something like that, would be enough? Other interesting and/or sane defaults
could go into that vhosts.conf file, and could even be commented out by default
in order to keep the current behaviour.
Comment 6 Rahul Sundaram 2006-10-04 14:00:33 EDT
dropping this off the FC6 blocker. 
Comment 7 Robert Scheck 2006-12-10 09:33:00 EST
Ping?
Comment 8 Joe Orton 2006-12-11 08:06:07 EST
Deciding what is appropriate for the default configuration and what is
appropriate to leave out is often very difficult.  

I've never really been convinced there is enough motivation to change the
default configuration like this; I can be swayed each way I try to decide on 
what to do with this bug :).  "Why not?" is certainly not a sufficient
motivation, nor is "because other distros do it".

My basic objection is that I don't want to get into prescribing config file
layout down to this level; it feels like "policy" where no policy is actually
necessary.  Making this change not only means updating the SELinux policy, it
also means changing where system-config-httpd puts vhost definitions, and that
gets this beyond trivial one-line changes.

The fact that we cannot define NameVirtualHost *:80 without also defining a
default *:80 vhost (which is not desirable) means you cannot just drop in new
name-based vhosts into a "vhosts.d", so it would be of restricted utility out of
the box.

So on balance my decision on this would be WONTFIX; I hope you can appreciate
that this is not being dismissed out of hand (or worse, out of laziness! :).
Comment 9 Joe Orton 2007-07-03 04:22:46 EDT
*** Bug 232393 has been marked as a duplicate of this bug. ***
Comment 10 Joe Orton 2007-07-03 04:25:37 EDT
*** Bug 246569 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.