Bug 246569 - Ship vh.d directory for virtual host configuration
Ship vh.d directory for virtual host configuration
Status: CLOSED DUPLICATE of bug 173012
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 02:03 EDT by Bojan Smojver
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 04:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file (22.64 KB, text/plain)
2007-07-03 02:03 EDT, Bojan Smojver
no flags Details
Configuration file patch (286 bytes, patch)
2007-07-03 02:05 EDT, Bojan Smojver
no flags Details | Diff
README file for vh.d directory (481 bytes, text/plain)
2007-07-03 02:05 EDT, Bojan Smojver
no flags Details
Spec file patch for conevenience (1.45 KB, patch)
2007-07-03 02:07 EDT, Bojan Smojver
no flags Details | Diff

  None (edit)
Description Bojan Smojver 2007-07-03 02:03:59 EDT
Description of problem:
It would be useful to have a /etc/httpd/vh.d directory where one could configure
virtual hosts, similar to the way modules are configured in conf.d. This
configuration after all other configuration directives (i.e. main and module
specific) have been applied, making sure all VHs inherit everything properly.


Version-Release number of selected component (if applicable):
2.2.4-4

How reproducible:
N/A

Steps to Reproduce:
N/A

  
Actual results:
N/A

Expected results:
N/A

Additional info:
This is an enhancement request, obviuosly.
Comment 1 Bojan Smojver 2007-07-03 02:03:59 EDT
Created attachment 158405 [details]
Spec file
Comment 2 Bojan Smojver 2007-07-03 02:05:02 EDT
Created attachment 158406 [details]
Configuration file patch
Comment 3 Bojan Smojver 2007-07-03 02:05:46 EDT
Created attachment 158407 [details]
README file for vh.d directory
Comment 4 Bojan Smojver 2007-07-03 02:07:42 EDT
Created attachment 158408 [details]
Spec file patch for conevenience
Comment 5 Bojan Smojver 2007-07-03 02:09:42 EDT
Sorry, the sentence should read:

This configuration would occur after all [...]
Comment 6 Bojan Smojver 2007-07-03 02:44:26 EDT
The benefit of this approach, which I failed to mention, is that default
httpd.conf can be delivered over RPM upgrades, therefore making deployment of
new defaults easier (i.e. no need for admins to merge .rpmnew stuff into the
config).
Comment 7 Joe Orton 2007-07-03 04:25:32 EDT
Thanks a lot for the hard work and patches - but (there's always a but :)... see
bug 173012 for the rationale why I don't think this is a good idea.

*** This bug has been marked as a duplicate of 173012 ***
Comment 8 Bojan Smojver 2007-07-03 18:02:02 EDT
That's cool - it's not a big deal for me to add this one line to the back of
httpd.conf. I was just lazy and wanted to avoid editing httpd.conf every time I
upgrade my Fedora/EL boxes. It's also kind of cool to get defaults by default ;-)

Related to the rationale from bug #173012, this problem:

"The fact that we cannot define NameVirtualHost *:80 without also defining a
default *:80 vhost (which is not desirable) means you cannot just drop in new
name-based vhosts into a "vhosts.d", so it would be of restricted utility out of
the box."

is trivially fixed by having a .conf file in vh.d (or whatever it's called) that
is alphabetically before anything else (e.g. starting with _), which then
includes user specified NameVirtualHost directive (and any other user-overriden
global directives), without the need for httpd.conf (or anything in conf.d) to
carry that. This can be mentioned in the vh.d/README.

SELinux thing isn't a big deal. Policy changes all the time.

I do get the point about system-config-httpd. This would need to be fixed for
something like this to work properly. Although I'm not a Python guy, it would
probably be good fun... :-)

Anyhow, if my persuasion isn't working (i.e. you still think this falls under
"why not"), feel free to leave WONTFIX - it's really not a big deal.

Note You need to log in before you can comment on or make changes to this bug.