Bug 173041 - xterm needs to be rebuilt for modular X
xterm needs to be rebuilt for modular X
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: xorg-modular
  Show dependency treegraph
 
Reported: 2005-11-12 17:04 EST by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-13 04:26:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2005-11-12 17:04:53 EST
Description of problem:

xterm needs to be rebuilt for modular X or it'll block the upgrade
It should be made available on prc with the other modular X packages

Current xterm won't work with modular X:

Missing Dependency: libXaw.so.7()(64bit) is needed by package xterm

But it can not be removed with the current X version installed:

# rpm -e xterm
error: Failed dependencies:
        xterm is needed by (installed) xinitrc-4.0.19-1.noarch

# rpm -e xinitrc
error: Failed dependencies:
        xinitrc is needed by (installed) xorg-x11-6.8.2-62.x86_64
        xinitrc >= 0:3.33-1 is needed by (installed) gdm-2.8.0.4-8.x86_64
        /etc/X11/xdm/Xsession is needed by (installed) gdm-2.8.0.4-8.x86_64
Comment 1 Mike A. Harris 2005-11-12 17:51:05 EST
xterm should not have any Xorg release specific dependency.  What you are
reporting above, does not appear to be a bug in xterm at all IMHO.

Xterm is linked to libXaw, which is provided by both the monolithic and
modular X trees (or it wouldn't be X anymore).  xterm should work with
either of them.

Do not mix and match monolithic and modular X rpms.  This will not work.
If you decide to install the experimental modular X rpms - any of them,
you _must_ remove all of monolithic X completely, and ensure that yum
repositories you have configured, do not contain monolithic X, or yum will
re-install monolithic X.

error: Failed dependencies:
        xterm is needed by (installed) xinitrc-4.0.19-1.noarch

This is not an xterm dependency on xinitrc.  It is an xinitrc dependency on
xterm.  The "failsafe" desktop setting uses xterm currently, so xterm must
be installed for failsafe to work.

The "xinitrc" package is replaced by "xorg-x11-xinit" in modular X BTW.


I don't see any bug here from what you've posted above.
Comment 2 Mike A. Harris 2005-11-12 17:52:21 EST
oh, xdm's configuration files are now in xorg-x11-xdm package too BTW.
Comment 3 Nicolas Mailhot 2005-11-12 19:36:40 EST
The problem is when you do an update from current xorg to modular xorg

xterm and xinitrc should be replaced during the upgrade, since as you note
they're linked to the xorg version and should not be mixed with the new one

However since there's nothing in your modular xorg tree that can replace them,
the upgrade fails.

In the current state, when modular X will hit rawhide no one will be able to use
it till xterm is bumped too

A workaround would be to remove them, but as the dependency chain shows you can
not create a sane state without xterm but with monolithic xorg from which to
update to modular xorg
Comment 4 Mike A. Harris 2005-11-13 04:26:02 EST
You're not upgrading properly.  The Obsoletes lines in the modular packaging
handle things just fine.  If you try to manually update one package at a time
by hand, you _will_ end up in a massive complicated mess.

xorg-x11-xinit obsoletes "xinitrc" and also provides it.  When modular X
is upgraded to in one large transaction set, it will remove xinitrc package,
and replace it with the new xinit package.

Please do not file bugs just because you can't figure out how to properly
upgrade to modular X by hand.  It is not intended that end users try to
upgrade one package at a time, something that is this huge and complicated,
unless they understand how to dig themselves out of the dependency chain
which is involved - which tools like yum/up2date will handle automatically.

Also note that you are probably not using the latest modular X packages,
as I have not made them publically available. Reopening bugs that don't
exist and causing me to spend time on them, is just delaying me from
getting modular X out the door.  Please use the mailing lists to discuss
problems first.

If a number of *developers* believe that you have encountered a bug, then
please file it in bugzilla.

Note You need to log in before you can comment on or make changes to this bug.