This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 171376 - (xorg-modular) Xorg X11R7 modular release target tracker
Xorg X11R7 modular release target tracker
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On: X11R6-MIGRATE 171875 172488 172489 xorg-bad-deps 172610 172656 172997 173027 173036 173041 173042 173045 173059 173060 173063 173064 173065 173081 173083 173084 173160 173268 173282 173292 173348 173361 173371 xorg-horror-story 173389 173423 rgb.txt gccmakedep-missing 173483 173593 173629 173648 173665 173684 173702 173710 173943 174103
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-10-21 06:54 EDT by Mike A. Harris
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 05:11:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2005-10-21 06:54:21 EDT
This is a tracker bug, tracking issues found in X11R7 which need to be
fixed before it can be included in rawhide.  This also includes tracking
bugs or changes in other packages that need to be fixed/changed.  There
may be a need for sub-trackers as well to link to this bug.

I've filed it against xorg-x11 as this is the easiest way to track the
issue, even though there wont be an "xorg-x11" component in FC5 once
modular X is integrated.
Comment 1 Mike A. Harris 2005-10-21 07:09:06 EDT
Packages to migrate from /usr/X11R6 to /usr:
  alias "X11R6-MIGRATE"
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167600

Packages that use imake, need updating for X.Org X11R7 for FC5
  alias "fc5-imake"
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169208

Comment 2 Nicolas Mailhot 2005-11-07 05:10:04 EST
Packages that need to have deps fixed to work with modular xorg:
  alias "xorg-bad-deps"
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=172558
Comment 3 Mike A. Harris 2006-02-02 04:51:38 EST
As mentioned in comment #0, this tracker was intended to track problems that
should be fixed /before/ the X11R7 codebase should end up in rawhide.  Currently,
X11R7 has long since been integrated into rawhide though, so the meaning of
this bug has diverged from the original intention a bit.  ;o)

The remaining bugs that are still open and blocking the closure of this one,
include 2 groups of issues:

1) Issues that definitely must be fixed before FC5
2) Issues that should be fixed, or it would be nice to fix before FC5

FC5Blocker tracks category 1, and FC5Target tracks category 2.

This particular tracking bug is no longer useful, and all of the bugs
that are still open that it is tracking should be removed from blocking
this bug, and added to one of the other trackers above.

If anyone feels up to taking this to task, it would be appreciated and
very helpful, however I'll eventually get around to it myself if there
are no volunteers.

Comment 4 Mike A. Harris 2006-02-02 05:11:18 EST
Actually, I decided to go ahead and do it myself.  Only took 25 minutes,
plus cleaned up some other bug issues along the way.

Setting status to "RAWHIDE" now.

Note You need to log in before you can comment on or make changes to this bug.