Bug 1730541 - [ceph-validate] : lvm scenario : abort site-docker .yml if GPT headers are found on devices
Summary: [ceph-validate] : lvm scenario : abort site-docker .yml if GPT headers are fo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.3
Hardware: Unspecified
OS: Unspecified
low
high
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Ameena Suhani S H
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 05:53 UTC by Vasishta
Modified: 2020-01-31 12:47 UTC (History)
9 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.1.rc12.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1731310 (view as bug list)
Environment:
Last Closed: 2020-01-31 12:46:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4241 'None' closed validate: fail if gpt header found on unprepared devices 2020-01-23 20:27:39 UTC
Github ceph ceph-ansible pull 4243 'None' closed validate: fail if gpt header found on unprepared devices (bp #4241) 2020-01-23 20:27:39 UTC
Red Hat Product Errata RHBA-2020:0312 None None None 2020-01-31 12:47:23 UTC

Description Vasishta 2019-07-17 05:53:05 UTC
Description of problem:
Cluster initialization failed saying "ceph-volume lvm batch: error: GPT headers found, they must be removed on: /dev/sdb". Tried a method to erase gpt headers from disk and re-initialized playbook, after running through all previous tasks again playbook failed saying the same reason.

As we have ceph-validate to per-check the feasibility of cluster creation, it would be a great improvisation from usability perspective if ceph-validate can fail playbook at early stage if GPT headers are present on a disk.

Version-Release number of selected component (if applicable):
ceph-ansible-3.2.20-1.el7cp.noarch
ceph-3.3-rhel-7-containers-candidate-14679-20190712005524

How reproducible:
Always (2/2)

Steps to Reproduce:
1. Make sure that you have gpt headers on disks meant to have OSD
2. Run site-docker.yml


Expected results:
ceph-validate must check whether the disk is feasible for complete OSD configuration.


Additional info:

Comment 5 Giridhar Ramaraju 2019-08-05 13:10:31 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 6 Giridhar Ramaraju 2019-08-05 13:11:33 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 9 errata-xmlrpc 2020-01-31 12:46:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.