Bug 1730685 - Minor upgrade fails on Controller node when using TLS with Octavia
Summary: Minor upgrade fails on Controller node when using TLS with Octavia
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z9
: 13.0 (Queens)
Assignee: Brent Eagles
QA Contact: Bruna Bonguardo
URL:
Whiteboard:
: 1733081 1733228 1740068 (view as bug list)
Depends On: 1741524 1743518
Blocks: 1664403 1740563
TreeView+ depends on / blocked
 
Reported: 2019-07-17 11:04 UTC by Yadnesh Kulkarni
Modified: 2019-12-11 11:52 UTC (History)
21 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.3.1-72.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1740563 (view as bug list)
Environment:
Last Closed: 2019-12-11 11:52:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1836729 None None None 2019-07-18 16:52:33 UTC
OpenStack gerrit 672713 'None' 'MERGED' 'Fix bogus reference to conditional in octavia upgrade tasks' 2019-12-02 14:06:37 UTC
OpenStack gerrit 673441 'None' 'MERGED' 'Fix bogus reference to conditional in octavia upgrade tasks' 2019-12-02 14:06:37 UTC
Red Hat Knowledge Base (Solution) 4363971 None None None 2019-09-10 14:31:49 UTC

Description Yadnesh Kulkarni 2019-07-17 11:04:44 UTC
Description of problem:

The update fails with the below error
~~~
TASK [remove TLS proxy if configured and running] ******************************
Thursday 11 July 2019  11:20:00 +0200 (0:00:00.102)       0:10:41.162 ********* 
fatal: [controller-os-2-dc2]: FAILED! => {"msg": "The conditional check 'internal_tls_enabled|bool' failed. The error was: error while evaluating conditional (internal_tls_enabled|bool): 'internal_tls_enabled' is undefined\n\nThe error appears to have been in '/var/lib/mistral/a34e8cd1-dbaf-4def-b091-2fb480f1694f/Controller2018/update_tasks.yaml': line 171, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n  when: step|int == 5\n- docker:\n  ^ here\n"}

PLAY RECAP *********************************************************************
controller-os-1-dc2        : ok=2    changed=0    unreachable=0    failed=0   
controller-os-2-dc2        : ok=53   changed=24   unreachable=0    failed=1   
controller-os-3-dc2        : ok=2    changed=0    unreachable=0    failed=0
~~~

Version-Release number of selected component (if applicable):
puppet-octavia-12.4.0-9.el7ost.noarch                       Wed Jul 10 18:32:00 2019
openstack-tripleo-heat-templates-8.3.1-54.el7ost.noarch     Wed Jul 10 18:33:44 2019

Zstream Release:
Red Hat OpenStack Platform release 13.0.7 (Queens)

Comment 2 Michael Johnson 2019-07-17 14:24:11 UTC
Brent, can you triage this issue?

Comment 5 Yadnesh Kulkarni 2019-07-22 09:10:10 UTC
Hello @Brent,

Could you please share the progress made till now to fix this issue?

This is customer's productions environment.

Regards,
Yadnesh K

Comment 6 Alex Stupnikov 2019-07-24 14:00:46 UTC
May I ask if we have some workaround to recommend to our customers?

Regards, Alex S.

Comment 9 Bruna Bonguardo 2019-07-25 13:35:29 UTC
*** Bug 1733228 has been marked as a duplicate of this bug. ***

Comment 10 Nir Magnezi 2019-07-31 14:23:44 UTC
*** Bug 1733081 has been marked as a duplicate of this bug. ***

Comment 11 Carlos Goncalves 2019-08-12 09:23:55 UTC
*** Bug 1740068 has been marked as a duplicate of this bug. ***

Comment 24 Lon Hohberger 2019-09-04 10:43:59 UTC
According to our records, this should be resolved by openstack-tripleo-heat-templates-8.3.1-79.el7ost.  This build is available now.


Note You need to log in before you can comment on or make changes to this bug.