Bug 1730744 - Swift capabilities tests fail when being run against Rados GW
Summary: Swift capabilities tests fail when being run against Rados GW
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z11
: 13.0 (Queens)
Assignee: Chandan Kumar
QA Contact: Martin Kopec
URL:
Whiteboard:
Depends On:
Blocks: 1795825 1801143
TreeView+ depends on / blocked
 
Reported: 2019-07-17 14:00 UTC by Andre
Modified: 2020-03-10 11:53 UTC (History)
9 users (show)

Fixed In Version: openstack-tempest-18.0.0-12.el7ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-10 11:52:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1799981 0 None None None 2019-07-17 14:00:03 UTC
OpenStack gerrit 615558 0 'None' ABANDONED Add api_prefix for check capabilities 2020-05-27 13:39:02 UTC
OpenStack gerrit 692375 0 None MERGED Accept custom registered endpoints 2020-05-27 13:39:02 UTC
Red Hat Product Errata RHBA-2020:0769 0 None None None 2020-03-10 11:53:28 UTC

Description Andre 2019-07-17 14:00:03 UTC
Description of problem:
Keep track of the upstream launchpad bug[1]
Customer is hitting the same issue with OSP13.

[1] https://bugs.launchpad.net/tempest/+bug/1799981


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Andre 2019-07-23 14:36:54 UTC
Hi,

Customer tried applying the code from https://review.opendev.org/#/c/615558/ and it worked for him.
Do we have any update on this case? With this confirmation and also this bug report from the customer, can we reactivate the code review with +1s?

Comment 4 Martin Kopec 2019-09-29 21:58:57 UTC
I was testing the patch proposed upstream and find a few more things which need to be addressed here. 
See comment #3 in the linked Launchpad bug for more info and example tracebacks: https://bugs.launchpad.net/tempest/+bug/1799981/comments/3

Comment 19 Martin Kopec 2020-02-20 23:04:13 UTC
The fix is included in openstack-tempest-18.0.0-12.el7ost.
Automated jobs seem to work so the BZ can be moved to VERIFIED, my manual testing concludes that result as well.

Comment 21 errata-xmlrpc 2020-03-10 11:52:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0769


Note You need to log in before you can comment on or make changes to this bug.