Bug 1730912 - awscli not upgradable due to pyyaml being too new
Summary: awscli not upgradable due to pyyaml being too new
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: awscli
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Duncan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1758555 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 20:53 UTC by Kevin Fenzi
Modified: 2019-10-26 17:27 UTC (History)
16 users (show)

Fixed In Version: awscli-1.16.263-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-26 17:27:11 UTC


Attachments (Terms of Use)

Description Kevin Fenzi 2019-07-17 20:53:29 UTC
- nothing provides python3.7dist(pyyaml) <= 5.1 needed by awscli-1.16.198-1.fc31.noarch

indeed, in setup.py: 
    requires.append('PyYAML>=3.10,<=5.1')

and
✗ sudo dnf repoquery --whatprovides 'python3.7dist(pyyaml)'
Last metadata expiration check: 0:04:04 ago on Wed 17 Jul 2019 01:48:06 PM PDT.
python3-pyyaml-0:5.1.1-2.fc31.x86_64

So, I guess check with upstream why they are requiring less than 5.1?

Comment 1 Ben Cotton 2019-08-13 16:57:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 19:00:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 David Duncan 2019-08-13 19:06:26 UTC
Requesting help on this from aws-sdk team.

Comment 4 David Duncan 2019-08-14 13:59:36 UTC
https://github.com/aws/aws-cli/pull/4403 - Bumped the version to 5.2.

Comment 5 TR Bentley 2019-09-22 06:13:51 UTC
Any update on this as the Fedora 31 is unable to access AWS components from any scripts.

Comment 6 David Duncan 2019-09-26 03:45:48 UTC
Updated and completed. Upstream fix in place.

Comment 7 TR Bentley 2019-10-02 18:32:09 UTC
Are there any plans to fix this in F31 or do we need to wait to f32 for the fixes.

Comment 8 James Hogarth 2019-10-07 12:58:10 UTC
*** Bug 1758555 has been marked as a duplicate of this bug. ***

Comment 9 James Hogarth 2019-10-07 13:00:48 UTC
This still uninstallable and I don't even see any test builds of the upstream release that fixes this https://apps.fedoraproject.org/packages/awscli/builds/

We're about to enter FinalFreeze with GA only a couple of weeks away.

This is a key tool for a large number of people.

What's the plan to fix this?

Will a ProvenPackager need to intervene to ensure that it isn't broken when F31 releases?

Comment 10 James Hogarth 2019-10-07 14:34:52 UTC
I've carried out a scratch build of the current rawhide spec for this and python-botocore against the F31-candidate target:

  * https://koji.fedoraproject.org/koji/taskinfo?taskID=38119003
  * https://koji.fedoraproject.org/koji/taskinfo?taskID=38118574

I've verified that these are installable in F31 (note that I had to bump the botocore_version requirement as rawhide has the botocore version out of sync with the expected version in the awscli spec/setuptools ... do these have to be so tightly bound together? If so can I please suggest a %check or a BuildRequires to enforce that this check is in place to prevent an awscli being built without a matching botocore available?):

```
[james.hogarth@localhost awscli]$ sudo dnf install https://kojipkgs.fedoraproject.org//work/tasks/9057/38119057/awscli-1.16.252-1.fc31.noarch.rpm https://kojipkgs.fedoraproject.org//work/tasks/8623/38118623/python3-botocore-1.12.243-1.fc31.noarch.rpm
Last metadata expiration check: 0:13:14 ago on Mon 07 Oct 2019 15:19:27 BST.
awscli-1.16.252-1.fc31.noarch.rpm                                                                                                                                                                             318 kB/s | 1.4 MB     00:04    
python3-botocore-1.12.243-1.fc31.noarch.rpm                                                                                                                                                                   389 kB/s | 3.3 MB     00:08    
Dependencies resolved.
==============================================================================================================================================================================================================================================
 Package                                                      Architecture                                       Version                                                       Repository                                                Size
==============================================================================================================================================================================================================================================
Installing:
 awscli                                                       noarch                                             1.16.252-1.fc31                                               @commandline                                             1.4 M
Upgrading:
 python3-botocore                                             noarch                                             1.12.243-1.fc31                                               @commandline                                             3.3 M

Transaction Summary
==============================================================================================================================================================================================================================================
Install  1 Package
Upgrade  1 Package

Total size: 4.7 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                                                                      1/1 
  Upgrading        : python3-botocore-1.12.243-1.fc31.noarch                                                                                                                                                                              1/3 
  Installing       : awscli-1.16.252-1.fc31.noarch                                                                                                                                                                                        2/3 
  Cleanup          : python3-botocore-1.12.188-2.fc31.noarch                                                                                                                                                                              3/3 
  Running scriptlet: python3-botocore-1.12.188-2.fc31.noarch                                                                                                                                                                              3/3 
  Verifying        : awscli-1.16.252-1.fc31.noarch                                                                                                                                                                                        1/3 
  Verifying        : python3-botocore-1.12.243-1.fc31.noarch                                                                                                                                                                              2/3 
  Verifying        : python3-botocore-1.12.188-2.fc31.noarch                                                                                                                                                                              3/3 

Upgraded:
  python3-botocore-1.12.243-1.fc31.noarch                                                                                                                                                                                                     

Installed:
  awscli-1.16.252-1.fc31.noarch                                                                                                                                                                                                               

Complete!

```

Incidentally the changelog for these are in the wrong format and need fixing whilst the F31 update is being carried out anyway ...

The missing brackets on the email are causing the parsing to break:

  * https://apps.fedoraproject.org/packages/awscli/changelog/
  * https://apps.fedoraproject.org/packages/python3-botocore/changelog/

Comment 11 Yogesh Sharma 2019-10-10 13:10:57 UTC
tested, works for me.

Comment 12 David Duncan 2019-10-10 14:58:03 UTC
There was an issue with the cli build in the current version. 1.16.253 is being built now.

Comment 13 Eric Paris 2019-10-14 17:50:55 UTC
I can't get the awscli-1.16.253-2.fc32 package to install on f31 because of all sorts of python dependency issues.
Any chance you could rebuild awscli-1.16.198-2.fc31 with the spec fix so we had something in 31?

Thank you!

Comment 14 James Hogarth 2019-10-15 08:45:15 UTC
David you need to build a fixed version for F31, not just build for Rawhide.

We're now in FinalFreeze with an uninstallable awscli on F31

Are you going to be able to resolve this?

The schedule has the actual release in a week, this needs to be fixed ASAP if awscli is going to be installable at release, and if upgrades are not going to break (or remove awscli).

@Eric: I'm not sure what "CLI" issue David is referring to, but you can give my scratch build in koji linked previously a go at need.

Comment 15 James Hogarth 2019-10-15 08:48:20 UTC
Oh and the changelog is still the wrong format ... please fix it so the tools can properly parse it.

Comment 16 Peter Robinson 2019-10-18 18:58:25 UTC
(In reply to David Duncan from comment #12)
> There was an issue with the cli build in the current version. 1.16.253 is
> being built now.

Any reason not to "git merge master" this for F-31, as it's not install-able there ATM?

Comment 17 M. Edward (Ed) Borasky 2019-10-21 07:57:03 UTC
Still not working in F31 beta - I'm dropping back to a container to run `aws-cli`

Comment 18 James Hogarth 2019-10-21 08:09:29 UTC
Okay this has gone on long enough I think ... I'll fix this up myself as an urgent issue.

David feel free to contact me directly if you'd like to discuss ways to avoid this happening in future.

Comment 19 Fedora Update System 2019-10-21 08:35:51 UTC
FEDORA-2019-94473553fc has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-94473553fc

Comment 20 James Hogarth 2019-10-21 08:37:11 UTC
Since this is so close to release the auto-stable time is 7 days in bodhi but the karma threshold is only 3.

Please test the update and provide feedback to get the fix out ASAP.

Comment 21 Fedora Update System 2019-10-21 14:35:14 UTC
awscli-1.16.263-2.fc31, python-botocore-1.12.253-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-94473553fc

Comment 22 David Duncan 2019-10-21 16:54:20 UTC
Hi james, thanks for fixing this. I apologize for missing on it. I was confused about the build process. I am typically building a new one for rawhide ~daily now, but I am not backporting any changes since this is such a fast moving project. 

This relax-dependencies patch requirement has been removed as a result of an upstream decision to remove the ceilings from the versions.

Comment 23 M. Edward (Ed) Borasky 2019-10-21 17:35:46 UTC
I couldn't get it to work from testing - probably the mirror hasn't updated yet. But I did get it installed and working from https://bodhi.fedoraproject.org/updates/FEDORA-2019-94473553fc

Comment 24 Fedora Update System 2019-10-26 17:27:11 UTC
awscli-1.16.263-2.fc31, python-botocore-1.12.253-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.