Bug 1730927 - Gnome Software unable to download updates
Summary: Gnome Software unable to download updates
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 32
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 22:06 UTC by Dima Ryazanov
Modified: 2020-11-09 20:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 14:37:25 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot (53.27 KB, image/png)
2019-07-17 22:06 UTC, Dima Ryazanov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-software - issues 793 0 None None None 2020-07-30 22:18:55 UTC

Internal Links: 1800854

Description Dima Ryazanov 2019-07-17 22:06:28 UTC
Created attachment 1591602 [details]
Screenshot

When I try to download updates, I consistently get an error message:

"""
Unable to download updates:
could not do untrusted question as no klass support
"""

Refreshing the updates doesn't change anything.

When I run "sudo dnf update", I see:

"""
RPM Fusion for Fedora 30 - Free - Updates                                                                                                                                                        1.6 MB/s | 1.7 kB     00:00    
Importing GPG key 0xC0AEDA6E:
 Userid     : "RPM Fusion free repository for Fedora (30) <rpmfusion-buildsys@lists.rpmfusion.org>"
 Fingerprint: 80C3 B2C6 E727 F3E0 92B4 73E0 3DF2 CE43 C0AE DA6E
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-30
Is this ok [y/N]: 
"""

I'm guessing that's the cause of the error. However, if that's the case, Gnome Software needs to handle it somehow.

Comment 1 Dima Ryazanov 2019-11-12 00:36:25 UTC
Still a problem in Fedora 31.

Comment 2 Dima Ryazanov 2020-02-05 01:34:48 UTC
Seeing this again. Also found a forum thread about it: https://forums.fedoraforum.org/showthread.php?322093-Unable-to-download-updates-could-not-do-untrusted-question-as-no-klass-support

Comment 3 Slavic 2020-02-08 12:11:26 UTC
I have filed a similar report for Fedora 31. Should we updated the version here and mark mine as duplicate?

Comment 4 Ben Cotton 2020-04-30 20:27:59 UTC
This message is a reminder that Fedora 30 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 30 on 2020-05-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '30'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 30 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Ben Cotton 2020-05-26 14:37:25 UTC
Fedora 30 changed to end-of-life (EOL) status on 2020-05-26. Fedora 30 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 6 Eduardo Habkost 2020-07-07 16:06:09 UTC
Still reproducible on Fedora 32.

logs show the following:

Jul 07 12:04:02 PackageKit[387190]: get-updates transaction /2760_abbadecd from uid 1000 finished with success after 142ms
Jul 07 12:04:02 PackageKit[387190]: new update-packages transaction /2761_adbeacae scheduled from uid 1000
Jul 07 12:04:02 PackageKit[387190]: update-packages transaction /2761_adbeacae from uid 1000 finished with need-untrusted after 84ms

Comment 7 Federico Bruni 2020-07-27 19:24:27 UTC
Upstream issue:
https://gitlab.gnome.org/GNOME/gnome-software/-/issues/793

Comment 8 Sam Wachira 2020-11-09 20:39:11 UTC
Still a problem on Fedora 32. Trying to download Fedora 33 through gnome-software app fails with the same error.

Comment 9 Sam Wachira 2020-11-09 20:45:08 UTC
Check each non-Fedora .repo file in /etc/yum.repos.d which has 'gpgcheck=0' and set it 'enabled=0'.
Worked for me but would be nice to have a permanent solution.


Note You need to log in before you can comment on or make changes to this bug.