Bug 1731122 - [RFE] UI Bulk actions (delete), regression over old Insights
Summary: [RFE] UI Bulk actions (delete), regression over old Insights
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Cloud Software Services (cloud.redhat.com)
Classification: Red Hat
Component: Inventory
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: dhorton
QA Contact: Brandon Tweed
URL:
Whiteboard:
: 1734165 (view as bug list)
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2019-07-18 11:19 UTC by Peter Vreman
Modified: 2019-09-24 13:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-23 17:59:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peter Vreman 2019-07-18 11:19:36 UTC
Description of problem:
There is now a delete per system. To cleanup my current situation of obsoklete systems need to delete 50+ systems.
This is a very poor UX with the current implementation to click on the '...' and the delete per Hosts

As an user i expect the following use case that was working in old Insights:
- Working sorting (still not working !)
- Working filtering
- Select All
- Action - (Bulk) Delete


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create 500+ systems distributed with names starting A-Z
2. Delete systems stasrting with the letters M-P (~16% = ~80 systems)
3.

Actual results:
You need some cheap monks to do the work. Requiring 2-4hours of reperitive clicking. And finally still no garantuee that you deleted all M-P due to not working sorting/filtering

Expected results:
Delete succeeds with max 10 clicks within 10 seconds.

Additional info:

Comment 3 Rob Williams 2019-07-31 20:55:40 UTC
*** Bug 1734165 has been marked as a duplicate of this bug. ***

Comment 5 Ian Page Hands 2019-09-23 17:59:09 UTC
This bulk delete feature is pushed to Prod Stable.
The only thing we do not support at this time is "Select all on multiple pages".
We already support "Select all on current page".

Comment 6 Peter Vreman 2019-09-24 13:39:04 UTC
Ian

Confirming the bulk delete works in stable.
With a page size set to 100 the select all per page is good enough for me.

Peter


Note You need to log in before you can comment on or make changes to this bug.