Bug 1731656 - ImportError: libQt5Charts.so.5: cannot open shared object file: No such file or directory
Summary: ImportError: libQt5Charts.so.5: cannot open shared object file: No such file ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyqtchart
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1731655
TreeView+ depends on / blocked
 
Reported: 2019-07-20 15:12 UTC by Miro Hrončok
Modified: 2019-07-21 07:47 UTC (History)
2 users (show)

Fixed In Version: python-pyqtchart-5.12-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-21 07:47:56 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-07-20 15:12:41 UTC
$ rpm -q python3-pyqtchart
python3-pyqtchart-5.12-1.fc31.x86_64


>>> from PyQt5.QtChart import QChart, QLineSeries, QValueAxis
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: libQt5Charts.so.5: cannot open shared object file: No such file or directory

$ rpm -ql python3-pyqtchart | grep so$
/usr/lib64/python3.7/site-packages/PyQt5/QtChart.so


$ rpm -q --requires python3-pyqtchart
python(abi) = 3.7
python3-qt5
rpmlib...


While on my Fedora 30:

$ rpm -q --requires python3-pyqtchart-5.11.1-4.fc30.x86_64
libGL.so.1()(64bit)
libQt5Charts.so.5()(64bit)
libQt5Charts.so.5(Qt_5)(64bit)
libQt5Core.so.5()(64bit)
libQt5Core.so.5(Qt_5)(64bit)
libQt5Core.so.5(Qt_5.11)(64bit)
libQt5Gui.so.5()(64bit)
libQt5Gui.so.5(Qt_5)(64bit)
libQt5Widgets.so.5()(64bit)
libQt5Widgets.so.5(Qt_5)(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libm.so.6()(64bit)
libpthread.so.0()(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libstdc++.so.6(CXXABI_1.3.8)(64bit)
libstdc++.so.6(CXXABI_1.3.9)(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
python(abi) = 3.7
python3-qt5
rpmlib...

I belive this is a regression that was wrongfully covered by https://src.fedoraproject.org/rpms/python-pyqtchart/c/a796712eb0ec2bc877875584f057793161e11ca5?branch=master - temporarily disabling the debug_package - in fact, the package did not link properly.

Installing qt5-qtcharts manually workarounds the issue.

I'm going to add the dependency manually to unblock bz1731655, but this should be solved properly.

Comment 1 Miro Hrončok 2019-07-20 15:13:28 UTC
Rex, any idea what could have caused this?

Comment 2 Rex Dieter 2019-07-20 20:56:34 UTC
Make sure your *.so files are executable, otherwise rpm won't autodetect library dependencies.  See python-qt5 example,

https://src.fedoraproject.org/rpms/python-qt5/blob/master/f/python-qt5.spec#_327

Comment 3 Miro Hrončok 2019-07-20 22:36:00 UTC
Any idea why they suddenly stopped being executable?

Comment 4 Rex Dieter 2019-07-21 06:18:14 UTC
I don't know the cause unfortunately

Comment 5 Miro Hrončok 2019-07-21 07:47:56 UTC
Thanks for the pointer anyway.


Note You need to log in before you can comment on or make changes to this bug.